summaryrefslogtreecommitdiff
path: root/games-arcade/excido/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-arcade/excido/files
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/excido/files')
-rw-r--r--games-arcade/excido/files/excido-0.1.5c-build.patch29
-rw-r--r--games-arcade/excido/files/excido-0.1.5c-freealut.patch38
2 files changed, 0 insertions, 67 deletions
diff --git a/games-arcade/excido/files/excido-0.1.5c-build.patch b/games-arcade/excido/files/excido-0.1.5c-build.patch
deleted file mode 100644
index 1735b51ccdfc..000000000000
--- a/games-arcade/excido/files/excido-0.1.5c-build.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,8 +1,8 @@
--CC=g++
--CFLAGS=`sdl-config --cflags` #-g -Wall #-O2
-+CXX?=g++
-+CXXFLAGS+=$(shell sdl-config --cflags) #-g -Wall #-O2
- #CFLAGS=`sdl-config --cflags` -I./physfs#-g -Wall #-O2
- OBJS := ${patsubst %.cpp, %.o, ${wildcard src/*.cpp}}
--LIBS = -s -Bstatic `sdl-config --static-libs` -lSDL_image -lSDL_ttf -L. -lphysfs -lopenal -Bdynamic -lGL -lGLU
-+LIBS = $(shell sdl-config --libs) -lSDL_image -lSDL_ttf -lphysfs -lopenal -lalut -lGL -lGLU
- #LIBS = -s -Bstatic `sdl-config --static-libs` SDL_image/*.o SDL_ttf/*.o -L. physfs/*.o openal/*.o -ljpeg -lpng -ltiff -lfreetype -Bdynamic -lGL -lGLU
- PREFIX=/usr/local
- BINDIR=$(PREFIX)/bin/
-@@ -16,12 +16,12 @@
-
-
- .cpp.o:
-- $(CC) $(CFLAGS) $(DEFINES) -o ${patsubst %.cpp, %.o, $<} -c $<
-+ $(CXX) $(CXXFLAGS) $(DEFINES) -o ${patsubst %.cpp, %.o, $<} -c $<
-
- all: $(TARGET)
-
- $(TARGET): $(OBJS)
-- $(CC) $(CFLAGS) -o $(TARGET) $(LIBS) $(OBJS)
-+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
-
- clean:
- rm -f $(OBJS) $(TARGET)
diff --git a/games-arcade/excido/files/excido-0.1.5c-freealut.patch b/games-arcade/excido/files/excido-0.1.5c-freealut.patch
deleted file mode 100644
index c29999fae25d..000000000000
--- a/games-arcade/excido/files/excido-0.1.5c-freealut.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- a/src/SoundCore.cpp
-+++ b/src/SoundCore.cpp
-@@ -352,32 +352,13 @@
-
- PHYSFS_close(filehandle);
-
-- ALenum format;
-- ALvoid *data;
-- ALsizei size,freq;
-- ALboolean loop=AL_FALSE;
- ALenum error;
-
- alGetError();
-
-- alGenBuffers(1,&newsample.alid);
-- if((error=alGetError())!=AL_NO_ERROR){
-- fprintf(stderr,"SoundCore::LoadSample: Error on alGenBuffers\n");
-- PrintALError(error);
-- }
-- alutLoadWAVMemory((ALbyte*)filedata,&format,&data,&size,&freq,&loop);
-- if((error=alGetError())!=AL_NO_ERROR){
-- fprintf(stderr,"SoundCore::LoadSample: Error on alutLoadWAVMemory\n");
-- PrintALError(error);
-- }
-- alBufferData(newsample.alid,format,data,size,freq);
-- if((error=alGetError())!=AL_NO_ERROR){
-- fprintf(stderr,"SoundCore::LoadSample: Error on alBufferData\n");
-- PrintALError(error);
-- }
-- alutUnloadWAV(format,data,size,freq);
-- if((error=alGetError())!=AL_NO_ERROR){
-- fprintf(stderr,"SoundCore::LoadSample: Error on alutUnloadWAV\n");
-+ newsample.alid=alutCreateBufferFromFileImage(filedata, filesize);
-+ if(((error=alGetError())!=AL_NO_ERROR)||(newsample.alid==AL_NONE)){
-+ fprintf(stderr,"SoundCore::LoadSample: Error on alutCreateBufferFromFileImage\n");
- PrintALError(error);
- }
-