summaryrefslogtreecommitdiff
path: root/games-arcade/excido
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/excido
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/excido')
-rw-r--r--games-arcade/excido/Manifest5
-rw-r--r--games-arcade/excido/excido-0.1.5c-r3.ebuild40
-rw-r--r--games-arcade/excido/files/excido-0.1.5c-build.patch29
-rw-r--r--games-arcade/excido/files/excido-0.1.5c-freealut.patch38
-rw-r--r--games-arcade/excido/metadata.xml8
5 files changed, 120 insertions, 0 deletions
diff --git a/games-arcade/excido/Manifest b/games-arcade/excido/Manifest
new file mode 100644
index 000000000000..72a7e6885287
--- /dev/null
+++ b/games-arcade/excido/Manifest
@@ -0,0 +1,5 @@
+AUX excido-0.1.5c-build.patch 1033 BLAKE2B 171f87f9c08d51969af8e9171bbae2b177192afb9dad0dcf975fdc4a50ccfc961d5caa055830b929beadc3120f0a627c638371125ca93b4b8b642d4b3b1321d2 SHA512 9cd1b44ae83e9cf1171869124866df78f6d9bc2d18d80968937b7edf7d60dedef3cd0451fd3f81406e5b3b36960b3ac8f77032625e1c545f04d70998da8701ab
+AUX excido-0.1.5c-freealut.patch 1204 BLAKE2B 1aa65ee8e91f01be2ed6af6e45d945d81b1d6b5714072701a8b189b30668a7ef430bb08d54c322c487f0748c0112499c32b52273bc94e2746b687acdd9ea6134 SHA512 11c41ba18f2b698fa4eedfb93d670a09ddd6d954d9504903f51f6df23096e3f72f2836193ca35a5aeb6e3524ad887e1cbf0eb879583988dd99b0b4c439997a1c
+DIST excido-0.1.5c-src.tar.bz2 2981629 BLAKE2B 504c21861a4d966400a94ef6733794f72edbf950a84dcd935213244252b771e168f0bb5e21780c90d2cd1a1799cac821a502dbb558ffe6204d4b552e5af465d4 SHA512 9e1b98ed31eac735087f451c466d0e0d1b885ad5336f7994abf8f844b1c27cc24e90048306ffd62864fa5ab2bada6744b4b54991c6eb9b22624af20c645e02d7
+EBUILD excido-0.1.5c-r3.ebuild 789 BLAKE2B d4e7146161ecd604ff845b2de8b97e34633860cc38e32bf2e07b936db3dcaf79ab52b9e2ecee8a023fdbf07c0c11a8ac7008a979bbc8b82ad9ce063cd16966b1 SHA512 ace3ee24dbc3155db5f276922b1b5d570f0b15288711312711e9a7fb9bae8031c6e665673d005714807ddfcbf7fb799f58b78a0ac0fe28dbe8be271e8d04ee5a
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-arcade/excido/excido-0.1.5c-r3.ebuild b/games-arcade/excido/excido-0.1.5c-r3.ebuild
new file mode 100644
index 000000000000..cea4558b0b61
--- /dev/null
+++ b/games-arcade/excido/excido-0.1.5c-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A fast paced action game"
+HOMEPAGE="http://icculus.org/excido/"
+SRC_URI="http://icculus.org/excido/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-games/physfs
+ media-libs/libsdl[opengl]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-image[png]
+ media-libs/openal
+ media-libs/freealut"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-freealut.patch
+ "${FILESDIR}"/${P}-build.patch
+)
+
+src_compile() {
+ emake DATADIR=/usr/share/${PN}/
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins data/*
+ dodoc BUGS CHANGELOG HACKING README TODO \
+ keyguide.txt data/CREDITS data/*.txt
+}
diff --git a/games-arcade/excido/files/excido-0.1.5c-build.patch b/games-arcade/excido/files/excido-0.1.5c-build.patch
new file mode 100644
index 000000000000..1735b51ccdfc
--- /dev/null
+++ b/games-arcade/excido/files/excido-0.1.5c-build.patch
@@ -0,0 +1,29 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,8 @@
+-CC=g++
+-CFLAGS=`sdl-config --cflags` #-g -Wall #-O2
++CXX?=g++
++CXXFLAGS+=$(shell sdl-config --cflags) #-g -Wall #-O2
+ #CFLAGS=`sdl-config --cflags` -I./physfs#-g -Wall #-O2
+ OBJS := ${patsubst %.cpp, %.o, ${wildcard src/*.cpp}}
+-LIBS = -s -Bstatic `sdl-config --static-libs` -lSDL_image -lSDL_ttf -L. -lphysfs -lopenal -Bdynamic -lGL -lGLU
++LIBS = $(shell sdl-config --libs) -lSDL_image -lSDL_ttf -lphysfs -lopenal -lalut -lGL -lGLU
+ #LIBS = -s -Bstatic `sdl-config --static-libs` SDL_image/*.o SDL_ttf/*.o -L. physfs/*.o openal/*.o -ljpeg -lpng -ltiff -lfreetype -Bdynamic -lGL -lGLU
+ PREFIX=/usr/local
+ BINDIR=$(PREFIX)/bin/
+@@ -16,12 +16,12 @@
+
+
+ .cpp.o:
+- $(CC) $(CFLAGS) $(DEFINES) -o ${patsubst %.cpp, %.o, $<} -c $<
++ $(CXX) $(CXXFLAGS) $(DEFINES) -o ${patsubst %.cpp, %.o, $<} -c $<
+
+ all: $(TARGET)
+
+ $(TARGET): $(OBJS)
+- $(CC) $(CFLAGS) -o $(TARGET) $(LIBS) $(OBJS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
+
+ clean:
+ rm -f $(OBJS) $(TARGET)
diff --git a/games-arcade/excido/files/excido-0.1.5c-freealut.patch b/games-arcade/excido/files/excido-0.1.5c-freealut.patch
new file mode 100644
index 000000000000..c29999fae25d
--- /dev/null
+++ b/games-arcade/excido/files/excido-0.1.5c-freealut.patch
@@ -0,0 +1,38 @@
+--- a/src/SoundCore.cpp
++++ b/src/SoundCore.cpp
+@@ -352,32 +352,13 @@
+
+ PHYSFS_close(filehandle);
+
+- ALenum format;
+- ALvoid *data;
+- ALsizei size,freq;
+- ALboolean loop=AL_FALSE;
+ ALenum error;
+
+ alGetError();
+
+- alGenBuffers(1,&newsample.alid);
+- if((error=alGetError())!=AL_NO_ERROR){
+- fprintf(stderr,"SoundCore::LoadSample: Error on alGenBuffers\n");
+- PrintALError(error);
+- }
+- alutLoadWAVMemory((ALbyte*)filedata,&format,&data,&size,&freq,&loop);
+- if((error=alGetError())!=AL_NO_ERROR){
+- fprintf(stderr,"SoundCore::LoadSample: Error on alutLoadWAVMemory\n");
+- PrintALError(error);
+- }
+- alBufferData(newsample.alid,format,data,size,freq);
+- if((error=alGetError())!=AL_NO_ERROR){
+- fprintf(stderr,"SoundCore::LoadSample: Error on alBufferData\n");
+- PrintALError(error);
+- }
+- alutUnloadWAV(format,data,size,freq);
+- if((error=alGetError())!=AL_NO_ERROR){
+- fprintf(stderr,"SoundCore::LoadSample: Error on alutUnloadWAV\n");
++ newsample.alid=alutCreateBufferFromFileImage(filedata, filesize);
++ if(((error=alGetError())!=AL_NO_ERROR)||(newsample.alid==AL_NONE)){
++ fprintf(stderr,"SoundCore::LoadSample: Error on alutCreateBufferFromFileImage\n");
+ PrintALError(error);
+ }
+
diff --git a/games-arcade/excido/metadata.xml b/games-arcade/excido/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-arcade/excido/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>