summaryrefslogtreecommitdiff
path: root/games-arcade/komi/komi-1.04.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-arcade/komi/komi-1.04.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-arcade/komi/komi-1.04.ebuild')
-rw-r--r--games-arcade/komi/komi-1.04.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-arcade/komi/komi-1.04.ebuild b/games-arcade/komi/komi-1.04.ebuild
new file mode 100644
index 000000000000..3d4472a48c26
--- /dev/null
+++ b/games-arcade/komi/komi-1.04.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Komi the Space Frog - simple SDL game of collection"
+HOMEPAGE="http://komi.sourceforge.net"
+SRC_URI="mirror://sourceforge/komi/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+DOCS=( CHANGELOG.txt README.txt TROUBLESHOOTING.txt )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-DESTDIR.patch \
+ "${FILESDIR}"/${P}-install.patch
+ sed -i \
+ -e "/^BINPATH/s:=.*:=${GAMES_BINDIR}/:" \
+ -e "/^DATAPATH/s:=.*:=${GAMES_DATADIR}/${PN}/:" \
+ -e '/^SDL_LIB/s:$: $(LDFLAGS):' \
+ -e '/^SDL_LIB/s:--static-:--:' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake ECFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+ newicon komidata/sprites_komi.bmp ${PN}.bmp
+ make_desktop_entry komi Komi /usr/share/pixmaps/${PN}.bmp
+ doman komi.6
+ prepgamesdirs
+}