summaryrefslogtreecommitdiff
path: root/games-arcade/moleinvasion/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/moleinvasion/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/moleinvasion/files')
-rw-r--r--games-arcade/moleinvasion/files/moleinvasion-0.4-opengl.patch18
-rw-r--r--games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch11
2 files changed, 29 insertions, 0 deletions
diff --git a/games-arcade/moleinvasion/files/moleinvasion-0.4-opengl.patch b/games-arcade/moleinvasion/files/moleinvasion-0.4-opengl.patch
new file mode 100644
index 000000000000..357f1bc2b466
--- /dev/null
+++ b/games-arcade/moleinvasion/files/moleinvasion-0.4-opengl.patch
@@ -0,0 +1,18 @@
+--- src/MoleInvasion.c
++++ src/MoleInvasion.c
+@@ -159,6 +159,7 @@
+ else
+ printf("Video mode set to %ux%u at %u bpp\n",800, 600, bpp);
+
++ if(g_opengl) {
+ /* pour opengl */
+ glEnable (GL_TEXTURE_2D);
+ glTexParameteri (GL_TEXTURE_2D, GL_TEXTURE_MAG_FILTER, GL_LINEAR);
+@@ -169,6 +170,7 @@
+ glEnable( GL_BLEND );
+ glMatrixMode(GL_PROJECTION);
+ /* fin opengl */
++ }
+
+ /* titre */
+ SDL_WM_SetCaption ("Mole Invasion", NULL);
diff --git a/games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch b/games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch
new file mode 100644
index 000000000000..7ee61f91e378
--- /dev/null
+++ b/games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.old 2011-06-14 22:12:00.920386798 +0200
++++ b/Makefile 2011-06-14 22:12:22.118716548 +0200
+@@ -11,7 +11,7 @@
+ EDTOB = editor
+ EDWOB = editworld
+
+-LINLIBS=$(LDLIBS) -lGL
++LINLIBS=$(LDLIBS) -lGL -ldl
+ LINEXE = ../lin/moleinvasion
+ LINEDT = ../lin/editor
+ LINEDW = ../lin/editworld