summaryrefslogtreecommitdiff
path: root/games-arcade/opentyrian/files/2.1.20130907-datapath.diff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/opentyrian/files/2.1.20130907-datapath.diff
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/opentyrian/files/2.1.20130907-datapath.diff')
-rw-r--r--games-arcade/opentyrian/files/2.1.20130907-datapath.diff26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-arcade/opentyrian/files/2.1.20130907-datapath.diff b/games-arcade/opentyrian/files/2.1.20130907-datapath.diff
new file mode 100644
index 000000000000..5b0143ed9a50
--- /dev/null
+++ b/games-arcade/opentyrian/files/2.1.20130907-datapath.diff
@@ -0,0 +1,26 @@
+diff -uNr opentyrian-2.1.20130907.ORIG/Makefile opentyrian-2.1.20130907/Makefile
+--- opentyrian-2.1.20130907.ORIG/Makefile 2013-12-08 17:40:23.470846371 +0000
++++ opentyrian-2.1.20130907/Makefile 2013-12-08 17:40:49.355847165 +0000
+@@ -49,6 +49,10 @@
+ ALL_LDFLAGS += $(LDFLAGS)
+ LDLIBS += $(EXTRA_LDLIBS) $(SDL_LDLIBS)
+
++ifneq ($(DATA_PATH), )
++ CFLAGS += -DDATA_PATH=\"$(DATA_PATH)\"
++endif
++
+ # RULES ####################################################
+
+ .PHONY : all release clean
+diff -uNr opentyrian-2.1.20130907.ORIG/src/file.c opentyrian-2.1.20130907/src/file.c
+--- opentyrian-2.1.20130907.ORIG/src/file.c 2013-12-08 17:40:23.468846371 +0000
++++ opentyrian-2.1.20130907/src/file.c 2013-12-08 17:40:49.355847165 +0000
+@@ -34,7 +34,7 @@
+ #ifdef TARGET_MACOSX
+ tyrian_game_folder(),
+ #endif
+- "/usr/share/opentyrian/data"
++ DATA_PATH
+ };
+
+ static const char *dir = NULL;