summaryrefslogtreecommitdiff
path: root/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'games-arcade/pengupop/pengupop-2.2.5-r1.ebuild')
-rw-r--r--games-arcade/pengupop/pengupop-2.2.5-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild b/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
new file mode 100644
index 000000000000..6938c534c5c9
--- /dev/null
+++ b/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop gnome2-utils
+
+DESCRIPTION="Networked multiplayer-only Puzzle Bubble clone"
+HOMEPAGE="http://freshmeat.net/projects/pengupop"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eapply "${FILESDIR}"/${P}-underlink.patch
+
+ sed -i \
+ -e '/Icon/s/\.png//' \
+ -e '/^Encoding/d' \
+ -e '/Categories/s/Application;//' \
+ pengupop.desktop || die
+
+ sed -i \
+ -e 's/-g -Wall -O2/-Wall/' \
+ Makefile.am || die
+
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ domenu pengupop.desktop
+ doicon -s 48 pengupop.png
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}