summaryrefslogtreecommitdiff
path: root/games-arcade/solarwolf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/solarwolf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/solarwolf')
-rw-r--r--games-arcade/solarwolf/Manifest3
-rw-r--r--games-arcade/solarwolf/metadata.xml8
-rw-r--r--games-arcade/solarwolf/solarwolf-1.5-r1.ebuild36
3 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/solarwolf/Manifest b/games-arcade/solarwolf/Manifest
new file mode 100644
index 000000000000..d8bce2e450ac
--- /dev/null
+++ b/games-arcade/solarwolf/Manifest
@@ -0,0 +1,3 @@
+DIST solarwolf-1.5.tar.gz 2045888 BLAKE2B 66498b1d9b202b45ff87ea9d4b1ab14dcb6e343e8b0761576cfbf1c84ee9575cbf665e4b94552eb764f5e4fbaa02739f62c9eb20217085a6d18483d3ca7eb587 SHA512 44d84976f7797e3b859f1e5e50f9f964e5c6d6d4437ad25cf04720035e8697cc0c86490fdbbf8d923320a5c15c6e3afd1fbcfb9f17e7e31ce6f7264004e991f2
+EBUILD solarwolf-1.5-r1.ebuild 798 BLAKE2B ba969bfbaacf80d6a40385f4e6f60e603b0389287a1f71f541a9a9f87f98d9674ea63d167e07ff1b13a14669a074d6b45076d9c6740f1bf87ba8bb9b98894c28 SHA512 6e250abdab04450254a5d29bdb6aa8962c3a9194ade5eab8669b95db6ab9a620c1388a8a7a757ccc2f2b58de601d885b028c67add97a44373f5e12a4ab416218
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-arcade/solarwolf/metadata.xml b/games-arcade/solarwolf/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-arcade/solarwolf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-arcade/solarwolf/solarwolf-1.5-r1.ebuild b/games-arcade/solarwolf/solarwolf-1.5-r1.ebuild
new file mode 100644
index 000000000000..dc3d846b8b7a
--- /dev/null
+++ b/games-arcade/solarwolf/solarwolf-1.5-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Action/arcade recreation of SolarFox"
+HOMEPAGE="http://www.pygame.org/shredwheat/solarwolf/"
+SRC_URI="http://www.pygame.org/shredwheat/solarwolf/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/pygame-1.5.6
+ media-libs/sdl-mixer[mod,vorbis]
+"
+DEPEND=""
+
+src_prepare() {
+ default
+ find . -name .xvpics -print0 | xargs -0 rm -fr
+ gunzip dist/${PN}.6.gz || die #619948
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r code data *py
+ make_wrapper ${PN} "python2 ./solarwolf.py" /usr/share/${PN}
+ doicon dist/${PN}.png
+ make_desktop_entry ${PN} SolarWolf
+ einstalldocs
+ doman dist/${PN}.6
+}