summaryrefslogtreecommitdiff
path: root/games-arcade/stardork/stardork-0.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 13:42:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 13:42:21 +0100
commit22b51dcc430fb550fd692463a56cdcd5b18efd61 (patch)
tree1155e9ace7a82aac7ede90d7d5c2e79b0ec83918 /games-arcade/stardork/stardork-0.7-r2.ebuild
parent4b91667ebe695e6fdfbef3962d099f17484b8806 (diff)
gentoo auto-resync : 13:10:2022 - 13:42:21
Diffstat (limited to 'games-arcade/stardork/stardork-0.7-r2.ebuild')
-rw-r--r--games-arcade/stardork/stardork-0.7-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-arcade/stardork/stardork-0.7-r2.ebuild b/games-arcade/stardork/stardork-0.7-r2.ebuild
new file mode 100644
index 000000000000..f6b1fece5104
--- /dev/null
+++ b/games-arcade/stardork/stardork-0.7-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="ncurses-based space shooter"
+HOMEPAGE="https://stardork.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stardork/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_compile() {
+ tc-export CC
+ append-cppflags $($(tc-getPKG_CONFIG) ncurses --cflags || die)
+ append-libs $($(tc-getPKG_CONFIG) ncurses --libs || die)
+
+ emake -f /dev/null LDLIBS="${LIBS}" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}