summaryrefslogtreecommitdiff
path: root/games-arcade/triplexinvaders
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-arcade/triplexinvaders
reinit the tree, so we can have metadata
Diffstat (limited to 'games-arcade/triplexinvaders')
-rw-r--r--games-arcade/triplexinvaders/Manifest6
-rw-r--r--games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch62
-rw-r--r--games-arcade/triplexinvaders/metadata.xml12
-rw-r--r--games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild39
4 files changed, 119 insertions, 0 deletions
diff --git a/games-arcade/triplexinvaders/Manifest b/games-arcade/triplexinvaders/Manifest
new file mode 100644
index 000000000000..24034b04ae57
--- /dev/null
+++ b/games-arcade/triplexinvaders/Manifest
@@ -0,0 +1,6 @@
+AUX triplexinvaders-1.08-gentoo.patch 2297 SHA256 3b1c313be15f4f2e0a983acbae5aa9c3bf2e4cf7147f0e509f5f8fa678c391bf SHA512 21913469c9128df2fca3376b04da66e9f2be28eee1ddf1b3d4b2d4ebc90457984c18b0ec270d4115150877530ef4ea6dd2ddb1a86699986239e3e93a66f92a75 WHIRLPOOL a49a1f1c71f6b125e3db8df50177cce031b8465254486b10b70d1c91acd83bf7d32a0a5e3f8e1e43ba549c87c4772b6fa3969133621e960dfb2dd3b6f5dc1f9c
+DIST triplexinvaders-1.08.zip 354188 SHA256 ead4f0b139e487e742902e184ce146469d12ecc345d363147395c484cc8c4bfc SHA512 c763cf650046612152c9305a2067f52feedfeac5f16dd292031a184563f40efc9d95553bc01d59c5c6382394fd2a2d3fe971471cf775fe64c3b1f3c4842a0780 WHIRLPOOL 7c693962d0d0604d7b813ec051b3ecca050ae3ca7a25f0dd1fe5f7c11add4260e2ee080ffc62fa751e17388ee677485486f3d9be650232440275c3e45d58d707
+EBUILD triplexinvaders-1.08.ebuild 900 SHA256 64c0ee8f01e860ab052a6c111df59a246b338b0a227aa585874eb1041e4032b5 SHA512 977e2314297a029f4567af08a4a17af9132a960a1dc1715dc302467a73c7233bb985b6e3c41bb979afc97acedde56dfece679248b169f8a1deaf358b538320a3 WHIRLPOOL 74473c232188fc9c859c38fde179f6d68b582af8ff02d2f7a187735b47acd6ea77451eba0aea694f2b1b9390864014b66b93daf7c13eb5abf5ca359aab974152
+MISC ChangeLog 2497 SHA256 65ad80a9ab794e8b065fe05ee6a225af155e118ae8be1c65a446b4bf180daaa6 SHA512 899766f0c9a74316495ef940429cc81204018db9685495b2b0dd096db97c784cbf744308a36f19896c39b8acb546270fcd366166482208403e2e1a094964f56e WHIRLPOOL d8e5d57dea99c5a6309f844625c326b6cfef8079c85a39b339e308fb2e9a06f6e83bcce5476086c08e85a55600ed3ba02889b58747f3f85c98503e86084da8d9
+MISC ChangeLog-2015 1118 SHA256 ecd8eb7c190d894a3db3d72878799b10bac4f2319cc02703ff2eadaf1f441c48 SHA512 15a7c9c874d194adc13d912399faa90e545a7d24d503f56714e799a13e13474cc571d889e5ece4a6b0841d4e258dcb5c16abedfc0dca428f1ee77631009c8c60 WHIRLPOOL 429b01586f040ebb151965b87e60fbe0309e07ed8fa34b8f3dbcd5010be1f9c9aa0cfb774f7297e5efd6aafd70c514e54b96a702e4d1a5c5e2d5f8c098df9de7
+MISC metadata.xml 454 SHA256 c034e402426daef1687ab40f3eb25861573a49a71dae58e2385a40d003453d87 SHA512 bfd1ac0a3820beb15f021ab53527d316be512ed123f8eb7253c03efe82a569298b3474c7618e999cb134ea90aebb9d508909e5e938657e751fd9ac18552e6276 WHIRLPOOL fda9b22449f2940e05039421ef7c0c6212353131eefba93cfe2e11374134f031ec7bb29c2258c4338e808e35ea5269ab5e5577269feafb884ab0f4ebd240ba0d
diff --git a/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch b/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch
new file mode 100644
index 000000000000..56f9c1a1596a
--- /dev/null
+++ b/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch
@@ -0,0 +1,62 @@
+--- sound.py.old 2007-04-14 21:52:02.000000000 +0200
++++ sound.py 2007-04-14 21:52:27.000000000 +0200
+@@ -16,7 +16,7 @@
+
+
+ def reloadMusic():
+- pygame.mixer.music.load(os.path.join('sound', choice(music)))
++ pygame.mixer.music.load(os.path.join('@GENTOO_DATADIR@/sound', choice(music)))
+ pygame.mixer.music.set_endevent(ENDMUSIC)
+ pygame.mixer.music.play()
+
+@@ -24,7 +24,7 @@
+
+ def getSound(name, volume=0.4):
+ if name not in LoadedSounds:
+- sound = pygame.mixer.Sound(os.path.join('sound', '%s.ogg' % name))
++ sound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@/sound', '%s.ogg' % name))
+ sound.set_volume(volume)
+ LoadedSounds[name] = sound
+ return LoadedSounds[name]
+--- util.py.old 2007-04-14 21:56:30.000000000 +0200
++++ util.py 2007-04-14 21:56:48.000000000 +0200
+@@ -30,7 +30,7 @@
+ LoadedTextures = weakref.WeakValueDictionary()
+
+ def loadTexture(name):
+- filename = os.path.join('textures', '%s.png' % name)
++ filename = os.path.join('@GENTOO_DATADIR@/textures', '%s.png' % name)
+ textureSurface = pygame.image.load(filename)
+ textureData = pygame.image.tostring(textureSurface, "RGBA", True)
+ texid = glGenTextures(1)
+@@ -47,7 +47,7 @@
+
+ def getModel(name):
+ if name not in LoadedModels:
+- model = wavefront.load(os.path.join('models', '%s.obj' % name), name)
++ model = wavefront.load(os.path.join('@GENTOO_DATADIR@/models', '%s.obj' % name), name)
+ LoadedModels[name] = model
+ return LoadedModels[name]
+
+--- hiscore.py.old 2007-04-14 22:04:04.000000000 +0200
++++ hiscore.py 2007-04-14 22:04:25.000000000 +0200
+@@ -5,7 +5,7 @@
+ # copy the highscores to the user's homedir
+ highscorefile = os.path.join(configdir, 'hiscores')
+ if not os.path.exists(highscorefile):
+- oldpath = 'hiscores'
++ oldpath = '@GENTOO_DATADIR@/hiscores'
+ shutil.copy(oldpath, highscorefile)
+
+ def write(score, name):
+--- options.py.old 2007-04-14 22:05:23.000000000 +0200
++++ options.py 2007-04-14 22:05:42.000000000 +0200
+@@ -5,7 +5,7 @@
+ # copy the options to the user's homedir
+ optionfile = os.path.join(configdir, 'options.conf')
+ if not os.path.exists(optionfile):
+- oldpath = 'options.conf'
++ oldpath = '@GENTOO_DATADIR@/options.conf'
+ shutil.copy(oldpath, optionfile)
+
+ execfile(optionfile)
diff --git a/games-arcade/triplexinvaders/metadata.xml b/games-arcade/triplexinvaders/metadata.xml
new file mode 100644
index 000000000000..6ae220aaf948
--- /dev/null
+++ b/games-arcade/triplexinvaders/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+In Triplex Invaders, the player pilots a spaceship against a never ending horde
+of enemy ships. It has psychedelic 3d graphics (but 2d gameplay).
+</longdescription>
+</pkgmetadata>
diff --git a/games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild b/games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild
new file mode 100644
index 000000000000..89704df75b56
--- /dev/null
+++ b/games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="An Alien Invaders style game with 3d graphics"
+HOMEPAGE="http://triplexinvaders.infogami.com"
+SRC_URI="http://acm.jhu.edu/~arthur/invaders/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-python/pygame
+ dev-python/pyopengl"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-gentoo.patch
+ sed -i -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ sound.py \
+ util.py \
+ hiscore.py \
+ options.py || die "sed failed"
+}
+
+src_install() {
+ local libdir=$(games_get_libdir)
+
+ insinto "${libdir}/${PN}"
+ doins -r *.py
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r models sound options.conf hiscores
+ games_make_wrapper ${PN} "python ./invaders.py" "${libdir}/${PN}"
+ dodoc README.txt TODO.txt
+ prepgamesdirs
+}