summaryrefslogtreecommitdiff
path: root/games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild')
-rw-r--r--games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild b/games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild
new file mode 100644
index 000000000000..b1df215d59d0
--- /dev/null
+++ b/games-arcade/tuxpuck/tuxpuck-0.8.2-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Hover hockey"
+HOMEPAGE="http://home.no.net/munsuun/tuxpuck/"
+SRC_URI="http://home.no.net/munsuun/tuxpuck/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl
+ media-libs/libpng:0=
+ virtual/jpeg:0
+ media-libs/libvorbis
+"
+DEPEND="${RDEPEND}
+ media-libs/freetype:2
+"
+
+src_prepare() {
+ default
+ # Bug #376741 - Make unpack call compatible with both
+ # PMS and <sys-apps/portage-2.1.10.10.
+ cd man || die
+ unpack ./${PN}.6.gz
+ cd .. || die
+ sed -i \
+ -e 's/-Werror//' \
+ -e '/^CC/d' \
+ Makefile \
+ utils/Makefile \
+ data/Makefile \
+ || die "sed failed"
+
+ eapply "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-png15.patch \
+ "${FILESDIR}"/${P}-parallel.patch
+}
+
+src_compile() {
+ emake -C utils
+ emake -C data
+ emake
+}
+
+src_install() {
+ dobin tuxpuck
+ doman man/tuxpuck.6
+ dodoc *.txt
+ doicon data/icons/${PN}.ico
+ make_desktop_entry ${PN} "TuxPuck" /usr/share/pixmaps/${PN}.ico
+ einstalldocs
+}