summaryrefslogtreecommitdiff
path: root/games-board/ascal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/ascal
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/ascal')
-rw-r--r--games-board/ascal/Manifest5
-rw-r--r--games-board/ascal/ascal-0.1.1-r1.ebuild37
-rw-r--r--games-board/ascal/files/ascal-0.1.1-gcc43.patch30
-rw-r--r--games-board/ascal/files/ascal-0.1.1-install.patch70
-rw-r--r--games-board/ascal/metadata.xml20
5 files changed, 162 insertions, 0 deletions
diff --git a/games-board/ascal/Manifest b/games-board/ascal/Manifest
new file mode 100644
index 000000000000..ba8f53c53c7e
--- /dev/null
+++ b/games-board/ascal/Manifest
@@ -0,0 +1,5 @@
+AUX ascal-0.1.1-gcc43.patch 859 BLAKE2B 92b07bf43e9e64f9cdd505b9f048e7bd18ef6f9559242670793f2638d21ff43731bd4acbdda1be179fb04249a63b98bb0f854cd7c0e00d32d7119a0ee18aaa76 SHA512 e4d8b1fb25dda182fdbe9bddfee0157332337f6fa9865fa06b2fd8fa7cd16f03d8a25129ff233ea600dd9be32df93a2b591e47d9597fd547764af765f29dbab7
+AUX ascal-0.1.1-install.patch 1738 BLAKE2B 18f5aa5af12d14cd8f5fbf49864922232c1bc5b4cf15b5928bc900aa12bf8129578590f03ce449e8c26a2f44755e331501da9cc753d6964ba54f2738056f20e9 SHA512 a7ac59c7534461fc841ac9a7e60b7151408fe7f92728376a9ee4849c50ca460a67eacc055a67559b4c252b3d8d2f0504f464792a80ead7c5a7ffb325d07cc525
+DIST ascal-0.1.1.tar.bz2 960688 BLAKE2B b65011d9dbd7c6d088dc303312a5159a8e863713c64e10901b1cd34df561612003a9695d723c17c5a59b91e50a306760f3283abeeb333afad87d1fea6f758660 SHA512 4428040396da85dd8598ece34909b1db80fe2f72c36b8e0d23c3f9db5837ee30ec2a10ee74def97a80bafbbf1927cbdb6c598aa5f0a42949d3c490672f8c5165
+EBUILD ascal-0.1.1-r1.ebuild 673 BLAKE2B 0213597bfcd7be4f566f68f38fb58b55de999c4a7bbdb9b5ccc965588ecfe69fb27cdd36721657d6c574e5314905380c05e15770db5964d4ae33ea42e21788a2 SHA512 a46df9297a924eb4adb8c13da154803108dc88c863f3809797b31f2a6833542e5df79dc27310c03937747410dd7ee12995eb8fa1fee15374130f74a0f9d8db4e
+MISC metadata.xml 816 BLAKE2B 8e0ad192aae3d610f2f8d15922134871a049e85c330ab32eefe4948cb903957d90295d94dc6e3f5087ce5b326b4278bd7c62659e580abcf85da21f70005e5aec SHA512 eccb593e64f1dd07427835d43a350796e21445c9fd39df3ef82c01dcf12d008bc4e6551df78637c55191f16849a801f725f57a6368b16372d68013a26a1ff809
diff --git a/games-board/ascal/ascal-0.1.1-r1.ebuild b/games-board/ascal/ascal-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..33cafc7a58d9
--- /dev/null
+++ b/games-board/ascal/ascal-0.1.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A game similar to Draughts but with some really cool enhancements"
+HOMEPAGE="http://ascal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ascal/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-cpp/libglademm
+ dev-cpp/libgnomecanvasmm
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-install.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf
+}
diff --git a/games-board/ascal/files/ascal-0.1.1-gcc43.patch b/games-board/ascal/files/ascal-0.1.1-gcc43.patch
new file mode 100644
index 000000000000..b2a55584fb0b
--- /dev/null
+++ b/games-board/ascal/files/ascal-0.1.1-gcc43.patch
@@ -0,0 +1,30 @@
+--- a/src/gui.cpp 2009-01-18 21:11:58.000000000 +0100
++++ b/src/gui.cpp 2009-01-18 21:12:33.000000000 +0100
+@@ -21,6 +21,7 @@
+ #include "shareddata.hpp"
+ #include "config.h"
+ #include <string>
++#include <libintl.h>
+
+ gui::gui(shareddata *newData): GuiBoard() {
+ //clean, cleaner - pointer ;)
+--- a/src/gui_board.cpp 2009-01-18 21:13:30.000000000 +0100
++++ b/src/gui_board.cpp 2009-01-18 21:13:50.000000000 +0100
+@@ -20,6 +20,7 @@
+ #include <math.h>
+ #include "helper.h"
+ #include <stack>
++#include <libintl.h>
+
+
+ gui_board::gui_board() {
+--- a/src/board.cpp 2009-01-18 21:14:27.000000000 +0100
++++ b/src/board.cpp 2009-01-18 21:14:58.000000000 +0100
+@@ -15,6 +15,7 @@
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+ #include "board.hpp"
++#include <cstdlib>
+ //#define DEBUG
+ #include "ourmove.hpp"
+ #include "helper.h"
diff --git a/games-board/ascal/files/ascal-0.1.1-install.patch b/games-board/ascal/files/ascal-0.1.1-install.patch
new file mode 100644
index 000000000000..51a82a535eb8
--- /dev/null
+++ b/games-board/ascal/files/ascal-0.1.1-install.patch
@@ -0,0 +1,70 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -63,9 +63,6 @@
+ AC_DEFINE(DEBUG, 1, [Enable debug msg.])
+ CPPFLAGS=[`echo "$CXXFLAGS" | $SED -e 's/-O[0-9]*//g'`]
+ CPPFLAGS="$CPPFLAGS -g -O0"
+-else
+- CPPFLAGS=[`echo "$CXXFLAGS" | $SED -e 's/-O[0-9]*//g'`]
+- CPPFLAGS="$CPPFLAGS -O3"
+ fi
+
+ AC_ARG_ENABLE(Werror,
+@@ -74,7 +71,7 @@
+ )
+
+ if test "$enable_Werror" = yes; then
+- CPPFLAGS="$CPPFLAGS -Werror -Wall"
++ CPPFLAGS="$CPPFLAGS -Wall"
+ fi
+
+ AC_ARG_ENABLE(static,
+--- a/m4/Makefile.am
++++ b/m4/Makefile.am
+@@ -15,6 +15,5 @@
+ m4macros =
+
+ # The following is boilerplate
+-m4data_DATA = $(m4macros)
+ EXTRA_DIST =
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -17,13 +17,12 @@
+
+ ACLOCAL_AMFLAGS = -I m4
+
+-pixmapdir = $(datadir)/pixmaps
++pixmapdir = /usr/share/pixmaps
+ pixmap_DATA = ascal.png
+
+-desktopdir = $(datadir)/applications
++desktopdir = /usr/share/applications
+ desktop_in_files = ascal.desktop.in
+-desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+
+ @INTLTOOL_DESKTOP_RULE@
+
+-#include aminclude.am
+\ No newline at end of file
++#include aminclude.am
+--- a/po/Makefile.in.in
++++ b/po/Makefile.in.in
+@@ -34,7 +34,7 @@
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+-itlocaledir = $(prefix)/$(DATADIRNAME)/locale
++itlocaledir = /usr/share/locale
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -50,5 +50,5 @@
+
+
+
+-INCLUDES = $(ASCAL_CFLAGS) $(GTKMM) -DLOCALEDIR=\""$(datadir)/locale"\" -DASCAL_DATA_PREFIX=\""$(ASCAL_DATA_PREFIX)"\"
++INCLUDES = $(ASCAL_CFLAGS) $(GTKMM) -DLOCALEDIR=\""/usr/share/locale"\" -DASCAL_DATA_PREFIX=\""$(ASCAL_DATA_PREFIX)"\"
+ LIBS = $(ASCAL_LIBS) $(GTKMM)
diff --git a/games-board/ascal/metadata.xml b/games-board/ascal/metadata.xml
new file mode 100644
index 000000000000..3fbc824d750e
--- /dev/null
+++ b/games-board/ascal/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+Lasca (or Laska) is a game similar to Draughts but with some really cool
+enhancements. You'll find a great description in the help system of Ascal. In
+the meantime the article on Wikipedia and on
+http://research.interface.co.uk/lasca/about.htm will help you understanding the
+rules. Ascal tries to give a great Gnome Version of Lasca for one and two
+players. You can undo moves, save and load games and all that on a nifty
+graphical board.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ascal</remote-id>
+ </upstream>
+</pkgmetadata>