summaryrefslogtreecommitdiff
path: root/games-board/maitretarot/maitretarot-0.1.98-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /games-board/maitretarot/maitretarot-0.1.98-r2.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'games-board/maitretarot/maitretarot-0.1.98-r2.ebuild')
-rw-r--r--games-board/maitretarot/maitretarot-0.1.98-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-board/maitretarot/maitretarot-0.1.98-r2.ebuild b/games-board/maitretarot/maitretarot-0.1.98-r2.ebuild
new file mode 100644
index 000000000000..a53f75ae021d
--- /dev/null
+++ b/games-board/maitretarot/maitretarot-0.1.98-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Server for the french tarot game maitretarot"
+HOMEPAGE="http://www.nongnu.org/maitretarot/"
+SRC_URI="https://savannah.nongnu.org/download/maitretarot/${PN}.pkg/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ dev-games/libmaitretarot"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format.patch
+)
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+
+ # Remove bundled macros (avoid patching same file multiple times)
+ rm -rf m4/{libmaitretarot,libmt_client}.m4 || die
+
+ # Ensure we generate auto* with the fixed macros in tree
+ # (not bundled)
+ # bug #739142
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-default-config-file="/etc/maitretarotrc.xml"
+}