summaryrefslogtreecommitdiff
path: root/games-board/natch/natch-2.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-board/natch/natch-2.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-board/natch/natch-2.4-r1.ebuild')
-rw-r--r--games-board/natch/natch-2.4-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-board/natch/natch-2.4-r1.ebuild b/games-board/natch/natch-2.4-r1.ebuild
new file mode 100644
index 000000000000..8b263b424b33
--- /dev/null
+++ b/games-board/natch/natch-2.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+MY_P="Natch-${PV}"
+DESCRIPTION="A program to solve chess proof games"
+HOMEPAGE="http://natch.free.fr/Natch.html"
+SRC_URI="http://natch.free.fr/Natch/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format.patch
+)
+
+src_install() {
+ newbin src/Natch natch
+ dodoc AUTHORS ChangeLog NEWS README THANKS example.txt
+}