summaryrefslogtreecommitdiff
path: root/games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild')
-rw-r--r--games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild b/games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild
new file mode 100644
index 000000000000..9d1c1b6e3896
--- /dev/null
+++ b/games-board/openyahtzee/openyahtzee-1.9.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0"
+inherit flag-o-matic toolchain-funcs wxwidgets
+
+DESCRIPTION="A full-featured wxWidgets version of the classic dice game Yahtzee"
+HOMEPAGE="http://openyahtzee.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openyahtzee/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+
+pkg_pretend() {
+ local ver=4.6
+ local msg="You need at least GCC ${ver}.x for C++11 range-based 'for' and nullptr support."
+
+ if tc-is-gcc ; then
+ if ver_test ${ver} -gt $(gcc-version); then
+ die ${msg}
+ fi
+ else
+ ewarn "Ensure your compiler has C++11 support, otherwise build will fail."
+ fi
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ setup-wxwidgets
+ econf --datadir=/usr/share
+}