summaryrefslogtreecommitdiff
path: root/games-board/openyahtzee
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
commit51536d2fe4697ba9114d611178bb9e20d3d5b729 (patch)
tree30b91d98e65985a575940ed49e756697c1f049c2 /games-board/openyahtzee
parent4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (diff)
gentoo resync : 23.12.2017
Diffstat (limited to 'games-board/openyahtzee')
-rw-r--r--games-board/openyahtzee/Manifest1
-rw-r--r--games-board/openyahtzee/files/openyahtzee-1.9.2-wx3.0.patch67
2 files changed, 0 insertions, 68 deletions
diff --git a/games-board/openyahtzee/Manifest b/games-board/openyahtzee/Manifest
index 978e425932af..7296f363c5ec 100644
--- a/games-board/openyahtzee/Manifest
+++ b/games-board/openyahtzee/Manifest
@@ -1,4 +1,3 @@
-AUX openyahtzee-1.9.2-wx3.0.patch 2477 BLAKE2B ae4630ce86fe7e44fd627353c91ef5f4ae0740afd426770d3755503583c4a0c8e078802aa4a50a7bae7397378849d63c9677d43cbaafa04de0f316b333dc3009 SHA512 2c06b591c105ea757d4b00ada15272899ea4c43e8c8ab770112950fa5754fff139494cdec784e7826c1fff44e5fac0d9a70442555ef4421bb2ee05d554e2c788
DIST openyahtzee-1.9.3.tar.xz 178868 BLAKE2B 0cb5b87f8d4f9cdfbc81918f937ec783fef2488146f5497de0d01d6b50eeeef2edc308ca4230f1103b5770a03ccb74740e5c42b2ea01bd67705ed2aff6667d99 SHA512 7e696141d8f567247300c7f4924889b0a2f88866c70a10ad7619709990cacb726ec0af28bcee62a9f0d607d7f83ca5bb62d7275b2cc6e0343004f9125e4fb506
EBUILD openyahtzee-1.9.3.ebuild 937 BLAKE2B dbc52d1d309360507c5260c151bc48a881be4925b5fc48e185264a7136565aea3fbd30cddf1a67375f1176dc18e58e7e328649c07dbe6ba3a8ddfe39df1a0453 SHA512 c213cf1063433df039abe8daf8f74e6f378c0f6f9353d80c12b5caa32c1a8c604570d9e54f269f0ce554adf83a644fccb90be40454faec1759ca4fe027d201f0
MISC metadata.xml 462 BLAKE2B df86908050673276a1a63ed0c15cf798092cdb4caa47097cc1e96781d1afc11b08ccbf25598e40357c0c13ed3ba27508820d45bb73930ab137d00999abdabd36 SHA512 a2a3cb524e9432f9e439fd7f1bff4885ffca9230df17e5ad1f529710e606e34f5a65f0b880fd538d8dcccc228cba9672b8267fa17f8f2d477f7da416cbb8a7bc
diff --git a/games-board/openyahtzee/files/openyahtzee-1.9.2-wx3.0.patch b/games-board/openyahtzee/files/openyahtzee-1.9.2-wx3.0.patch
deleted file mode 100644
index 485a14c9ceeb..000000000000
--- a/games-board/openyahtzee/files/openyahtzee-1.9.2-wx3.0.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From: Guy Rutenberg <guyrutenberg@gmail.com>
-Date: Sat, 25 Oct 2014 15:33:42 +0200
-Subject: wxstrtol
-
-Fixes a FTBFS with recent versions of wx3.0.
----
- src/MainFrame.cpp | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/src/MainFrame.cpp b/src/MainFrame.cpp
-index 2128376..8e29d6d 100644
---- a/src/MainFrame.cpp
-+++ b/src/MainFrame.cpp
-@@ -510,7 +510,7 @@ void MainFrame::OnUndo(wxCommandEvent& event)
- wxString tempstr;
-
- tempstr = ((wxTextCtrl*) FindWindow(ID_YAHTZEEBONUSTEXT)) -> GetValue();
-- tempstr.Printf(wxT("%li"), wxStrtol(tempstr, NULL, 10) - 100);
-+ tempstr.Printf(wxT("%li"), strtol(tempstr.mb_str(), NULL, 10) - 100);
- ((wxTextCtrl*) FindWindow(ID_YAHTZEEBONUSTEXT)) -> SetValue(tempstr);
- }
-
-@@ -936,7 +936,7 @@ void MainFrame::YahtzeeBonus()
- return;
- if (m_score_dice.IsYahtzee()) {
- tempstr = ((wxTextCtrl*) FindWindow(ID_YAHTZEEBONUSTEXT)) -> GetValue();
-- tempstr.Printf(wxT("%li"), wxStrtol(tempstr, NULL, 10) + 100);
-+ tempstr.Printf(wxT("%li"), strtol(tempstr.mb_str(), NULL, 10) + 100);
- ((wxTextCtrl*) FindWindow(ID_YAHTZEEBONUSTEXT)) -> SetValue(tempstr);
- m_yahtzeebonus = true;
- }
-@@ -973,7 +973,7 @@ void MainFrame::EndofGame()
-
- for (int i = ID_ACESTEXT; i<=ID_SIXESTEXT; i++){
- tempstr = ((wxTextCtrl*) FindWindow(i)) -> GetValue();
-- upperscore += wxStrtol(tempstr, NULL, 10);
-+ upperscore += strtol(tempstr.mb_str(), NULL, 10);
- }
-
- tempstr.Printf(wxT("%li"),upperscore);
-@@ -992,7 +992,7 @@ void MainFrame::EndofGame()
- //calculate total on lower section
- for (int i = ID_THREEOFAKINDTEXT; i<=ID_YAHTZEEBONUSTEXT; i++) {
- tempstr = ((wxTextCtrl*) FindWindow(i)) -> GetValue();
-- lowerscore += wxStrtol(tempstr, NULL, 10);
-+ lowerscore += strtol(tempstr.mb_str(), NULL, 10);
- }
-
- tempstr.Printf(wxT("%li"),lowerscore);
-@@ -1091,7 +1091,7 @@ void MainFrame::CalculateSubTotal()
-
- for (int i = ID_ACESTEXT; i<=ID_SIXESTEXT; i++){
- tempstr = ((wxTextCtrl*) FindWindow(i)) -> GetValue();
-- upperscore += wxStrtol(tempstr, NULL, 10);
-+ upperscore += strtol(tempstr.mb_str(), NULL, 10);
- }
-
- tempstr.Printf(wxT("%li"),upperscore);
-@@ -1105,7 +1105,7 @@ void MainFrame::CalculateSubTotal()
-
- for (int i = ID_THREEOFAKINDTEXT; i<=ID_YAHTZEEBONUSTEXT; i++) {
- tempstr = ((wxTextCtrl*) FindWindow(i)) -> GetValue();
-- lowerscore += wxStrtol(tempstr, NULL, 10);
-+ lowerscore += strtol(tempstr.mb_str(), NULL, 10);
- }
-
- tempstr.Printf(wxT("%li"),lowerscore);