summaryrefslogtreecommitdiff
path: root/games-board/scid/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /games-board/scid/files
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'games-board/scid/files')
-rw-r--r--games-board/scid/files/scid-4.6.2-pgnfix-python3.patch1
-rw-r--r--games-board/scid/files/scid-4.7.0-system-gtest.patch16
-rw-r--r--games-board/scid/files/scid-4.7.0-tcl-start-path.patch7
3 files changed, 24 insertions, 0 deletions
diff --git a/games-board/scid/files/scid-4.6.2-pgnfix-python3.patch b/games-board/scid/files/scid-4.6.2-pgnfix-python3.patch
index 79b64e5ef6f3..264849c0eb30 100644
--- a/games-board/scid/files/scid-4.6.2-pgnfix-python3.patch
+++ b/games-board/scid/files/scid-4.6.2-pgnfix-python3.patch
@@ -1,3 +1,4 @@
+https://sourceforge.net/p/scid/patches/8/
--- a/scripts/pgnfix.py
+++ b/scripts/pgnfix.py
@@ -12,7 +12,6 @@
diff --git a/games-board/scid/files/scid-4.7.0-system-gtest.patch b/games-board/scid/files/scid-4.7.0-system-gtest.patch
new file mode 100644
index 000000000000..4e4a38cdc934
--- /dev/null
+++ b/games-board/scid/files/scid-4.7.0-system-gtest.patch
@@ -0,0 +1,16 @@
+--- a/gtest/CMakeLists.txt
++++ b/gtest/CMakeLists.txt
+@@ -19,8 +19,3 @@
+ # googletest
+-if(NOT IS_DIRECTORY "${CMAKE_BINARY_DIR}/googletest")
+- find_package(Git)
+- execute_process(COMMAND ${GIT_EXECUTABLE} clone https://github.com/google/googletest.git)
+-endif()
+-set(gtest_force_shared_crt ON CACHE BOOL "Always use msvcrt.dll")
+-add_subdirectory(${CMAKE_BINARY_DIR}/googletest ${CMAKE_BINARY_DIR}/googletest/Build EXCLUDE_FROM_ALL)
++find_package(GTest REQUIRED)
+
+@@ -48,2 +43,2 @@
+ target_compile_definitions(scid_tests PRIVATE -DSCID_TESTDIR=\"${CMAKE_CURRENT_LIST_DIR}/\")
+-target_link_libraries(scid_tests PRIVATE scid_base gtest_main)
++target_link_libraries(scid_tests PRIVATE scid_base ${GTEST_BOTH_LIBRARIES})
diff --git a/games-board/scid/files/scid-4.7.0-tcl-start-path.patch b/games-board/scid/files/scid-4.7.0-tcl-start-path.patch
new file mode 100644
index 000000000000..361700d7bc84
--- /dev/null
+++ b/games-board/scid/files/scid-4.7.0-tcl-start-path.patch
@@ -0,0 +1,7 @@
+--- a/src/ui_tcltk.h
++++ b/src/ui_tcltk.h
+@@ -59,3 +59,3 @@
+ else dirname += 1;
+- strcpy (dirname, "tcl/start.tcl");
++ strcpy (dirname, "../share/scid/tcl/start.tcl");
+ if (0 != Tcl_Access(sourceFileName, 4)) {