summaryrefslogtreecommitdiff
path: root/games-board/tali/tali-40.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-09 00:17:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-09 00:17:07 +0000
commit4fc232f0223106ced390fbe949c095cb39143f23 (patch)
treecbe7ad1f19d2a427ec23a82842e743a1aa49cd49 /games-board/tali/tali-40.9.ebuild
parent2237cda0c6b012952e02ec1314e1f48eddf4dab7 (diff)
gentoo auto-resync : 09:01:2023 - 00:17:07
Diffstat (limited to 'games-board/tali/tali-40.9.ebuild')
-rw-r--r--games-board/tali/tali-40.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-board/tali/tali-40.9.ebuild b/games-board/tali/tali-40.9.ebuild
new file mode 100644
index 000000000000..417b0a30933d
--- /dev/null
+++ b/games-board/tali/tali-40.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Beat the odds in a poker-style dice game"
+HOMEPAGE="https://wiki.gnome.org/Apps/Tali https://gitlab.gnome.org/GNOME/tali"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+DEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.16:3
+ dev-libs/libgnome-games-support:1=
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/librsvg-2.32:2
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}