summaryrefslogtreecommitdiff
path: root/games-board/tetzle/tetzle-2.1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-23 12:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-23 12:07:24 +0100
commit57dda344760f34c8c8f93c3c161ab10e55dc3860 (patch)
treec16ee3911f3aa264b3e28d6cd1a834014f1c030f /games-board/tetzle/tetzle-2.1.3-r1.ebuild
parent98c7fa9070b6b423d52dfb59567ec7ef0d5f234d (diff)
gentoo auto-resync : 23:04:2023 - 12:07:24
Diffstat (limited to 'games-board/tetzle/tetzle-2.1.3-r1.ebuild')
-rw-r--r--games-board/tetzle/tetzle-2.1.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-board/tetzle/tetzle-2.1.3-r1.ebuild b/games-board/tetzle/tetzle-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..b47e7036d289
--- /dev/null
+++ b/games-board/tetzle/tetzle-2.1.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Jigsaw puzzle game that uses tetrominoes for the pieces"
+HOMEPAGE="https://gottcode.org/tetzle/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
+ einstalldocs
+}