summaryrefslogtreecommitdiff
path: root/games-board
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-23 19:24:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-23 19:24:10 +0000
commit575bcb9220287a6f0d2577db1fd9fe55d9d8b745 (patch)
tree52f12cfa140d4839d32305dd42eebe34e9686234 /games-board
parent4c5bd80830992553e02f099442277e10ee97372d (diff)
gentoo auto-resync : 23:02:2025 - 19:24:09
Diffstat (limited to 'games-board')
-rw-r--r--games-board/Manifest.gzbin9885 -> 9887 bytes
-rw-r--r--games-board/pysolfc/Manifest2
-rw-r--r--games-board/pysolfc/pysolfc-3.2.0.ebuild69
3 files changed, 71 insertions, 0 deletions
diff --git a/games-board/Manifest.gz b/games-board/Manifest.gz
index d2d0e3eb91dd..7e70c570f134 100644
--- a/games-board/Manifest.gz
+++ b/games-board/Manifest.gz
Binary files differ
diff --git a/games-board/pysolfc/Manifest b/games-board/pysolfc/Manifest
index ee76f61ba3d4..5cff23e66ad2 100644
--- a/games-board/pysolfc/Manifest
+++ b/games-board/pysolfc/Manifest
@@ -1,5 +1,7 @@
DIST PySolFC-3.1.0.tar.xz 32697568 BLAKE2B 9c303b24b9d3bbb2f10d66146a0e848158bb1dfa155aeeacbad4169fbec18d8bfd908b086836bafae93ec52a96c2a973550577dfc46ac8510614965637a78721 SHA512 fa8ccc06a8813e9935a7d3034fca1cf8723b5457b8ee575cce202911c5cef265f2d0b297b279ceae398a142b9da56d95f5bdbf193df18cb5acb6b8f285420259
+DIST PySolFC-3.2.0.tar.xz 32808092 BLAKE2B 04ca5567e67c32407135141b96d316e206093b712f0bac1761d2d46a729f8558f40794a5dc575cd420b92da8b5741eb5e7d57327ba756a997889174a31d07161 SHA512 190d20228585942ebf8be42514561a1642a2f102a4e32cf9e12d5b429f34279a447268839156d1e153be2147c152d738065bdbbc79d6494cfb9b5dcc901630d9
DIST PySolFC-Cardsets--Minimal-3.0.0.tar.xz 25188212 BLAKE2B a047a151b5c4256cfb0300c6bc75713db9aab63e4e76ba99233a59f39a9a7017406320a0e3b874b72084b3bccd14ca303f7af9666652efee85cf39803ad8c43c SHA512 9d4bacd072b450b29b9f1bec4557121a3647c2f837aeb6e249f452cb886467c5e7ca36dd36a78ea69a5c9df6f30d5245e12681d9d02fc9da2ece09c25d77e787
DIST PySolFC-Cardsets-3.0.tar.bz2 87075654 BLAKE2B 527463ba2abe22c553753f7cb8f6608867a3da01532461cd29b5cf007a49c242cbdbe82f50751283d17a46ecb15b263e324fbc1288b5c5eb3cc9bdc1cfc9b257 SHA512 4544bc8b890d0cd41d66bd513faf86c21455f4d0f154e567fd689917f2f3ca56fadf3ca9372bc80c5b1d5387aa4abfab7952e73024a3e41101112e716f80b762
EBUILD pysolfc-3.1.0.ebuild 1996 BLAKE2B fc72b4212f0855431e605497e8ea972e61b6c326147b03d804dfb9143a0753e8c360dd2abd84a43e0513a91e487926e3984c57078e2b8d2b9918674ea73388ec SHA512 607f115500e4336ff6d9f21456191150d7f76b37036211613b69a8669fe6cfa97bc63d0ebb32ea0b82951890aaed329b041d677e908e34b771524658d1891e21
+EBUILD pysolfc-3.2.0.ebuild 1968 BLAKE2B 0a8b494a2428b96cef970c749917cef219da3e49db17dc129e2c8062755178ea0723fa26c8f549986f54588c76090b8ea4b1b678da74110c1b0384a177359cd4 SHA512 d30a4101e29ced9d6fbaf36350e046810e3c86833498cc3445b3ddbdfc3693aab227f1d61db807590a9c5cf184cf3610e100cae275edfd6b6eb8177e653e1f0a
MISC metadata.xml 563 BLAKE2B 3b59b69697c8e2e34a4dad3f042639eeaf78e93167299d68ee17e7a0efb9417d78efb4d85be54b2dfa9710767abd4f1de5d9579e9f2ece656e39c286149eb5cc SHA512 6f27d71460517af500de23bc137225272c9ea45bf727725f2964a104ba48ac2a5464a930071d85e67ebf4f83b29a3359041ff8b4966b19459ed8e6cd7a24cb3f
diff --git a/games-board/pysolfc/pysolfc-3.2.0.ebuild b/games-board/pysolfc/pysolfc-3.2.0.ebuild
new file mode 100644
index 000000000000..2f66a9b5246f
--- /dev/null
+++ b/games-board/pysolfc/pysolfc-3.2.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="tk"
+inherit distutils-r1 xdg
+
+MY_PN="PySolFC"
+MY_P="${MY_PN}-${PV}"
+PS_CARD_P="${MY_PN}-Cardsets-3.0"
+PS_CARD_MIN_P="${MY_PN}-Cardsets--Minimal-3.0.0"
+
+DESCRIPTION="Exciting collection of more than 1000 solitaire card games"
+HOMEPAGE="https://pysolfc.sourceforge.io/"
+SRC_URI="
+ https://downloads.sourceforge.net/pysolfc/${MY_P}.tar.xz
+ extra-cardsets? ( https://downloads.sourceforge.net/pysolfc/${PS_CARD_P}.tar.bz2 )
+ !extra-cardsets? ( https://downloads.sourceforge.net/pysolfc/${PS_CARD_MIN_P}.tar.xz )
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="extra-cardsets minimal +sound"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/pysol-cards[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
+ sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
+ !minimal? ( dev-python/pillow[jpeg,tk,${PYTHON_USEDEP}] )
+ ')
+ !minimal? ( dev-tcltk/tktable )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ if use extra-cardsets; then
+ find ../${PS_CARD_P} -type d -name .thumbnails -exec rm -r {} + || die
+ fi
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.md NEWS.asciidoc README.md )
+ distutils-r1_python_install_all
+
+ doman docs/pysol{,fc}.6
+
+ insinto /usr/share/${MY_PN}
+ doins -r ../$(usex extra-cardsets ${PS_CARD_P} ${PS_CARD_MIN_P})/.
+
+ # html files are used at runtime, keep at default location
+ dosym -r /usr/share/{${MY_PN},doc/${PF}}/html
+
+ # russian translation is not currently displaying right?
+ # (please report if works fine for you and this should be reverted)
+ # https://forums.gentoo.org/viewtopic-t-1142910.html
+ rm -- "${ED}"/usr/share/locale/ru/LC_MESSAGES/pysol.mo || die
+}