summaryrefslogtreecommitdiff
path: root/games-emulation/bsnes-jg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
commit3392d5e937023e57811edc670b0ed7d3aba55c6d (patch)
tree32c103a9b86223dcc05105e88f05d471bcaf0886 /games-emulation/bsnes-jg
parent046c3c0984fd20387a9f86cdd0842fd81e70d94f (diff)
gentoo auto-resync : 15:01:2023 - 17:55:24
Diffstat (limited to 'games-emulation/bsnes-jg')
-rw-r--r--games-emulation/bsnes-jg/Manifest4
-rw-r--r--games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild46
-rw-r--r--games-emulation/bsnes-jg/bsnes-jg-9999.ebuild46
-rw-r--r--games-emulation/bsnes-jg/metadata.xml21
4 files changed, 117 insertions, 0 deletions
diff --git a/games-emulation/bsnes-jg/Manifest b/games-emulation/bsnes-jg/Manifest
new file mode 100644
index 000000000000..90571dc14a77
--- /dev/null
+++ b/games-emulation/bsnes-jg/Manifest
@@ -0,0 +1,4 @@
+DIST bsnes-1.1.0.tar.bz2 4181355 BLAKE2B c60181208455f14c722073f7aa43b6b988aa46d8614cc8eae6e6b47acf1c5b30a94aa04410f873531e73637d3f11e25297dccc80b5c15c9fa4d4cc207083cef9 SHA512 39ee7e04dbeb021ac041ca3d189b86cf76f1994561c4bd1fd77a532e87ef4c135b177700b62f6e4f07018953c34f8602b5c4a43cd22d51dcd047df71e77e0412
+EBUILD bsnes-jg-1.1.0.ebuild 925 BLAKE2B ccb0f4598f2eab5163754395dc39c89e3e304d5b5b94f9ee97a1c818cb4fa4a75e6a863daea95d286031ed67c23680f8f19e9b2b75c764e97921d8d291489cdc SHA512 9ffb65e6c7b0040b2486569547101f6c0583961bafc0fca58d2f9b2e2ed31b2c9ebe59a5421286c04d389d293db1aacc65f82e098449f9819b822670aa1f5254
+EBUILD bsnes-jg-9999.ebuild 925 BLAKE2B ccb0f4598f2eab5163754395dc39c89e3e304d5b5b94f9ee97a1c818cb4fa4a75e6a863daea95d286031ed67c23680f8f19e9b2b75c764e97921d8d291489cdc SHA512 9ffb65e6c7b0040b2486569547101f6c0583961bafc0fca58d2f9b2e2ed31b2c9ebe59a5421286c04d389d293db1aacc65f82e098449f9819b822670aa1f5254
+MISC metadata.xml 742 BLAKE2B cade709bfd60e69c0c66654b409dbe59fd2c5bfe552d8bf226409b8a5e30d7b34e6934341d7678d241ffcf780dd69a0acd9d0d71f59e399c18d77447f6363e50 SHA512 a60107630d02ba44937e23b97b0b796c45653e8da85c3131bfc3d578683cc2d81194094bd8da44f19ff67c5e3c22eac175e078cecdfa20237f514130d10d4e5e
diff --git a/games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild b/games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild
new file mode 100644
index 000000000000..24d855263f55
--- /dev/null
+++ b/games-emulation/bsnes-jg/bsnes-jg-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of bsnes"
+HOMEPAGE="https://gitlab.com/jgemu/bsnes"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ISC GPL-3+ LGPL-2.1+ MIT ZLIB"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/libsamplerate
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/bsnes-jg/bsnes-jg-9999.ebuild b/games-emulation/bsnes-jg/bsnes-jg-9999.ebuild
new file mode 100644
index 000000000000..24d855263f55
--- /dev/null
+++ b/games-emulation/bsnes-jg/bsnes-jg-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of bsnes"
+HOMEPAGE="https://gitlab.com/jgemu/bsnes"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ISC GPL-3+ LGPL-2.1+ MIT ZLIB"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/libsamplerate
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/bsnes-jg/metadata.xml b/games-emulation/bsnes-jg/metadata.xml
new file mode 100644
index 000000000000..8d62f9db73ee
--- /dev/null
+++ b/games-emulation/bsnes-jg/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ bsnes-jg is a cycle accurate emulator for the Super Famicom/Super
+ Nintendo Entertainment System, including support for the Super Game Boy,
+ BS-X Satellaview, and Sufami Turbo.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/bsnes/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/bsnes</remote-id>
+ </upstream>
+</pkgmetadata>