summaryrefslogtreecommitdiff
path: root/games-emulation/bsnes-jg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-21 07:00:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-21 07:00:13 +0000
commit3faa6ebe0068b432ee5a9390c47ceca068ea7fe9 (patch)
treec571245b455a9a5dd80022270c5ac943532620b9 /games-emulation/bsnes-jg
parentee93fbc2bb111cf895ae00cc1877c68f0eafaf2a (diff)
gentoo auto-resync : 21:03:2024 - 07:00:13
Diffstat (limited to 'games-emulation/bsnes-jg')
-rw-r--r--games-emulation/bsnes-jg/Manifest2
-rw-r--r--games-emulation/bsnes-jg/bsnes-jg-1.1.2-r2.ebuild53
-rw-r--r--games-emulation/bsnes-jg/files/bsnes-jg-1.1.2-strict-aliasing.patch67
3 files changed, 122 insertions, 0 deletions
diff --git a/games-emulation/bsnes-jg/Manifest b/games-emulation/bsnes-jg/Manifest
index 6060a4d7ab95..47926823607f 100644
--- a/games-emulation/bsnes-jg/Manifest
+++ b/games-emulation/bsnes-jg/Manifest
@@ -1,5 +1,7 @@
AUX bsnes-jg-1.1.2-endianness.patch 3035 BLAKE2B 5b07ce5c7e4011fd69d97f812c64e95b31d26d8e403e84c3409c0f3bcdc9bf294c6114b288732e9e3cc6ec71d12f1498cd59f46f95de2a5aad8292aeb6693891 SHA512 b600dbbc27f497f45f9fa24acc74badbf63573114c7545c11de2571b65e249a1a8f46b5a4f0e23e0aff3884a9049c1302c92922274323273e7a72e1cae3babf8
+AUX bsnes-jg-1.1.2-strict-aliasing.patch 2277 BLAKE2B c91b7e92e387c812c368e3f7e6838200e51b0a9fb076a14c334650fb2e8522465bd21f9fa1afab855e5d10cc2749ee160f7573cdf34b5e00d2000baa2f6e962d SHA512 e02244bdcda681fa1cd80a6ab6863d46009afc8f35ad04821905266510f615bc5782b51196176c3d02c48e1ce8155567c246b23cc0332889e4f5347bc35a787b
DIST bsnes-1.1.2.tar.bz2 4183035 BLAKE2B 09e01845fb9e6208f5262e2abef14c46e9fa53cfdd025821345507fc68e520dc21ca69e5d712a7f821936166975865c26dc0be42549b551abdbb941e748949b1 SHA512 77cb82b6cba2941813de25273bd74b928ad380dccadb909ae3500ddf6f8906504f5400df95381569d35fc7b06e0330f9eb4d54d88d64a5c698925d54df62bada
EBUILD bsnes-jg-1.1.2-r1.ebuild 1021 BLAKE2B 472a32182ab4808fffd7b25ee8c016cc9c3a4ba82806e9e6038dfdb367364911c9edd59a0bd73dcd4f7f64fd5fcd930ebc24bfe6643db5b5e36bca9517db7433 SHA512 399c4c2c286c930e348c1e03544d45c7de285b8a7fb8a71070c10263281fafd075f145d3eff03fa8911b1f2cf253e9c078c05d67f96dc2339f79a0c9b9b81e96
+EBUILD bsnes-jg-1.1.2-r2.ebuild 1122 BLAKE2B 7dbe634f8b4d9e74ee5e5756daf7910bb1009d21fedd5537b0935d9ddee4ae7c9276af095b09f6cde3f99cf1b89aae271c3c95801e547ee0c1fb8de7ac0c5e62 SHA512 998c3ab5d632aea162aec5ef4d504aec1637f272dc80a679013111753150de68a6867864ce5911af15d1014c837a183e1b8ad1c9ba0eafd53ae23693b3a131a9
EBUILD bsnes-jg-9999.ebuild 959 BLAKE2B d8cf4bd1c1d164e337b993d98c2c3251b14cc1ca7a5382212e1b625f987a1b49a30549b7daada9d8c9b3dc507443f6681ed259b1c1a09976cb0351085db03249 SHA512 b86890283e595d516d6e110b51f6fafa22ff6065fe57f179b183f6f417a2259ff36f90dc97f9c1360a5dd994a733e42ed6ab923bf31cc45df64331caf9b00856
MISC metadata.xml 742 BLAKE2B cade709bfd60e69c0c66654b409dbe59fd2c5bfe552d8bf226409b8a5e30d7b34e6934341d7678d241ffcf780dd69a0acd9d0d71f59e399c18d77447f6363e50 SHA512 a60107630d02ba44937e23b97b0b796c45653e8da85c3131bfc3d578683cc2d81194094bd8da44f19ff67c5e3c22eac175e078cecdfa20237f514130d10d4e5e
diff --git a/games-emulation/bsnes-jg/bsnes-jg-1.1.2-r2.ebuild b/games-emulation/bsnes-jg/bsnes-jg-1.1.2-r2.ebuild
new file mode 100644
index 000000000000..fe035e7a3b86
--- /dev/null
+++ b/games-emulation/bsnes-jg/bsnes-jg-1.1.2-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of bsnes"
+HOMEPAGE="https://gitlab.com/jgemu/bsnes"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="ISC GPL-3+ LGPL-2.1+ MIT ZLIB"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/libsamplerate
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://bugs.gentoo.org/891201#c9
+ "${FILESDIR}"/${P}-endianness.patch
+ # https://bugs.gentoo.org/926077
+ "${FILESDIR}"/${P}-strict-aliasing.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/bsnes-jg/files/bsnes-jg-1.1.2-strict-aliasing.patch b/games-emulation/bsnes-jg/files/bsnes-jg-1.1.2-strict-aliasing.patch
new file mode 100644
index 000000000000..106ea27730da
--- /dev/null
+++ b/games-emulation/bsnes-jg/files/bsnes-jg-1.1.2-strict-aliasing.patch
@@ -0,0 +1,67 @@
+https://bugs.gentoo.org/926077
+https://github.com/LIJI32/SameBoy/pull/593
+https://gitlab.com/jgemu/bsnes/-/merge_requests/419
+https://gitlab.com/jgemu/bsnes/-/commit/966545bb79cc9810fbcedbe34fd52f7b9b5ef04e
+
+From 966545bb79cc9810fbcedbe34fd52f7b9b5ef04e Mon Sep 17 00:00:00 2001
+From: Lior Halphon <LIJI32@gmail.com>
+Date: Sat, 9 Mar 2024 11:08:01 -0800
+Subject: [PATCH 1/2] Avoid strict aliasing violations. Closes #593
+
+Backported from:
+
+https://github.com/LIJI32/SameBoy/commit/8739da61c013e20e1cc94f0619c622a65c713408
+---
+ deps/gb/apu.c | 4 ++--
+ deps/gb/apu.h | 11 +++++++++++
+ 2 files changed, 13 insertions(+), 2 deletions(-)
+
+diff --git a/deps/gb/apu.c b/deps/gb/apu.c
+index e621e82a..0f0ed16b 100644
+--- a/deps/gb/apu.c
++++ b/deps/gb/apu.c
+@@ -100,7 +100,7 @@ static void update_sample(GB_gameboy_t *gb, GB_channel_t index, int8_t value, un
+ output.left = output.right = 0;
+ }
+
+- if (*(uint32_t *)&(gb->apu_output.current_sample[index]) != *(uint32_t *)&output) {
++ if (gb->apu_output.current_sample[index].packed != output.packed) {
+ refresh_channel(gb, index, cycles_offset);
+ gb->apu_output.current_sample[index] = output;
+ }
+@@ -131,7 +131,7 @@ static void update_sample(GB_gameboy_t *gb, GB_channel_t index, int8_t value, un
+ if (likely(!gb->apu_output.channel_muted[index])) {
+ output = (GB_sample_t){(0xF - value * 2) * left_volume, (0xF - value * 2) * right_volume};
+ }
+- if (*(uint32_t *)&(gb->apu_output.current_sample[index]) != *(uint32_t *)&output) {
++ if (gb->apu_output.current_sample[index].packed != output.packed) {
+ refresh_channel(gb, index, cycles_offset);
+ gb->apu_output.current_sample[index] = output;
+ }
+diff --git a/deps/gb/apu.h b/deps/gb/apu.h
+index c8700c80..15b54a87 100644
+--- a/deps/gb/apu.h
++++ b/deps/gb/apu.h
+@@ -25,11 +25,22 @@
+
+ /* APU ticks are 2MHz, triggered by an internal APU clock. */
+
++#ifdef GB_INTERNAL
++typedef union
++{
++ struct {
++ int16_t left;
++ int16_t right;
++ };
++ uint32_t packed;
++} GB_sample_t;
++#else
+ typedef struct
+ {
+ int16_t left;
+ int16_t right;
+ } GB_sample_t;
++#endif
+
+ typedef struct
+ {