summaryrefslogtreecommitdiff
path: root/games-emulation/cega-jg/cega-jg-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 11:50:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 11:50:23 +0100
commita2844b413d00a2859401e017a0311986151e1594 (patch)
tree3758da107fb05d4012a3f4813be2bf13c03d3985 /games-emulation/cega-jg/cega-jg-0.6.0.ebuild
parent1ac83daac7198a5717483e1cfab669ba4f12debe (diff)
gentoo auto-resync : 16:04:2023 - 11:50:23
Diffstat (limited to 'games-emulation/cega-jg/cega-jg-0.6.0.ebuild')
-rw-r--r--games-emulation/cega-jg/cega-jg-0.6.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-emulation/cega-jg/cega-jg-0.6.0.ebuild b/games-emulation/cega-jg/cega-jg-0.6.0.ebuild
new file mode 100644
index 000000000000..d75a4059c58a
--- /dev/null
+++ b/games-emulation/cega-jg/cega-jg-0.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good SG-1000, SMS, and Game Gear Emulator"
+HOMEPAGE="https://gitlab.com/jgemu/cega"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD MIT MPL-2.0 ZLIB"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/speexdsp
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}