summaryrefslogtreecommitdiff
path: root/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
commit2f8db31405fac68eea6f7257d58529243815033b (patch)
tree54259cc8988a98a10586fc0496b1f3501cd1e2a1 /games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
parenta4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (diff)
gentoo resync : 30.04.2018
Diffstat (limited to 'games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild')
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
new file mode 100644
index 000000000000..5d9acdc094b9
--- /dev/null
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
+HOMEPAGE="http://dgen.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dgen/files/${P}.tar.gz"
+
+LICENSE="dgen-sdl BSD BSD-2 free-noncomm LGPL-2.1+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="joystick opengl"
+
+RDEPEND="
+ media-libs/libsdl[joystick?,opengl?]
+ app-arch/libarchive
+ opengl? ( virtual/opengl )
+"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-joystick.patch )
+
+src_configure() {
+ econf \
+ $(use_enable x86 asm) \
+ $(use_enable joystick) \
+ $(use_enable opengl)
+}
+
+src_compile() {
+ emake -C musa m68kops.h
+ emake
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README sample.dgenrc" default
+}