summaryrefslogtreecommitdiff
path: root/games-emulation/dolphin/dolphin-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /games-emulation/dolphin/dolphin-9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'games-emulation/dolphin/dolphin-9999.ebuild')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index 09ecec7709c5..b63534d242d3 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -24,7 +24,7 @@ HOMEPAGE="https://www.dolphin-emu.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="alsa bluetooth discord-presence doc +evdev ffmpeg log lto profile pulseaudio +qt5 systemd upnp"
+IUSE="alsa bluetooth discord-presence doc +evdev ffmpeg log lto profile pulseaudio +qt5 systemd upnp vulkan"
RDEPEND="
dev-libs/hidapi:0=
@@ -130,6 +130,9 @@ src_prepare() {
l10n_find_plocales_changes "Languages/po/" "" '.po'
l10n_for_each_disabled_locale_do remove_locale
+
+ # About 50% compile-time speedup
+ use vulkan || sed -i -e '/Externals\/glslang/d' CMakeLists.txt
}
src_configure() {
@@ -146,6 +149,7 @@ src_configure() {
-DENABLE_PULSEAUDIO=$(usex pulseaudio)
-DENABLE_QT=$(usex qt5)
-DENABLE_SDL=OFF # not supported: #666558
+ -DENABLE_VULKAN=$(usex vulkan)
-DFASTLOG=$(usex log)
-DOPROFILING=$(usex profile)
-DUSE_DISCORD_PRESENCE=$(usex discord-presence)