summaryrefslogtreecommitdiff
path: root/games-emulation/dosbox/dosbox-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /games-emulation/dosbox/dosbox-9999.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'games-emulation/dosbox/dosbox-9999.ebuild')
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild48
1 files changed, 29 insertions, 19 deletions
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
index 8c4711e5620c..3292eebd77d5 100644
--- a/games-emulation/dosbox/dosbox-9999.ebuild
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -1,46 +1,56 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools desktop flag-o-matic
-GLIDE_PATCH=841e1071597b64ead14dd08c25a03206b2d1d1b6
-SRC_URI="glide? ( https://raw.githubusercontent.com/voyageur/openglide/${GLIDE_PATCH}/platform/dosbox/dosbox_glide.diff -> dosbox_glide-${GLIDE_PATCH}.diff )"
-
-if [[ ${PV} = 9999 ]]; then
+case "${PV}" in
+9999)
+ MY_P=${PN}
ESVN_REPO_URI="https://svn.code.sf.net/p/dosbox/code-0/dosbox/trunk"
inherit subversion
-else
- SRC_URI+=" mirror://sourceforge/dosbox/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
-fi
+ ;;
+*_pre*)
+ MY_PV=0-r${PV#*_pre}
+ MY_P=${PN}-code-${MY_PV}-${PN}-trunk
+ SRC_URI="https://sourceforge.net/code-snapshots/svn/d/do/dosbox/code-0/${MY_P}.zip"
+ BDEPEND="app-arch/unzip"
+ ;;
+*)
+ MY_PV=$(ver_rs 2 -)
+ MY_P=${PN}-${MY_PV}
+ SRC_URI="mirror://sourceforge/dosbox/${MY_P}.tar.gz"
+ ;;
+esac
+
+GLIDE_PATCH=841e1071597b64ead14dd08c25a03206b2d1d1b6
+SRC_URI+=" glide? ( https://raw.githubusercontent.com/voyageur/openglide/${GLIDE_PATCH}/platform/dosbox/dosbox_glide.diff -> dosbox_glide-${GLIDE_PATCH}.diff )"
DESCRIPTION="DOS emulator"
HOMEPAGE="https://www.dosbox.com/"
-
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS=""
IUSE="alsa +core-inline debug glide hardened opengl X"
-DEPEND="alsa? ( media-libs/alsa-lib )
+RDEPEND="alsa? ( media-libs/alsa-lib )
glide? ( media-libs/openglide )
opengl? ( virtual/glu virtual/opengl )
- debug? ( sys-libs/ncurses:0 )
+ debug? ( sys-libs/ncurses:0= )
X? ( x11-libs/libX11 )
media-libs/libpng:0=
- media-libs/libsdl[joystick,opengl?,video,X]
+ media-libs/libsdl[joystick,opengl?,video,X?]
media-libs/sdl-net
media-libs/sdl-sound
sys-libs/zlib"
-RDEPEND=${DEPEND}
-if [[ ${PV} = 9999 ]]; then
- S=${WORKDIR}/${PN}
-fi
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}"/${PN}-0.74-gcc46.patch
+ "${FILESDIR}"/${PN}-0.74-ncurses.patch
)
src_prepare() {