summaryrefslogtreecommitdiff
path: root/games-emulation/dosbox/dosbox-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /games-emulation/dosbox/dosbox-9999.ebuild
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'games-emulation/dosbox/dosbox-9999.ebuild')
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
index 786b1f786887..421603aa2fd0 100644
--- a/games-emulation/dosbox/dosbox-9999.ebuild
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,16 +21,18 @@ HOMEPAGE="http://dosbox.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="alsa debug glide hardened opengl"
+IUSE="alsa +core-inline debug glide hardened opengl X"
DEPEND="alsa? ( media-libs/alsa-lib )
glide? ( media-libs/openglide )
opengl? ( virtual/glu virtual/opengl )
debug? ( sys-libs/ncurses:0 )
- media-libs/libpng:0
- media-libs/libsdl[joystick,video,X]
+ X? ( x11-libs/libX11 )
+ media-libs/libpng:0=
+ media-libs/libsdl[joystick,opengl?,video,X]
media-libs/sdl-net
- media-libs/sdl-sound"
+ media-libs/sdl-sound
+ sys-libs/zlib"
RDEPEND=${DEPEND}
if [[ ${PV} = 9999 ]]; then
@@ -50,8 +52,10 @@ src_prepare() {
src_configure() {
use glide && append-cppflags -I"${EPREFIX}"/usr/include/openglide
+ ac_cv_lib_X11_main=$(usex X yes no) \
econf \
$(use_enable alsa alsa-midi) \
+ $(use_enable core-inline) \
$(use_enable !hardened dynamic-core) \
$(use_enable !hardened dynamic-x86) \
$(use_enable debug) \