summaryrefslogtreecommitdiff
path: root/games-emulation/dosbox/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /games-emulation/dosbox/files
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'games-emulation/dosbox/files')
-rw-r--r--games-emulation/dosbox/files/dosbox-0.74-gcc46.patch10
-rw-r--r--games-emulation/dosbox/files/dosbox-0.74-ncurses.patch72
-rw-r--r--games-emulation/dosbox/files/dosbox-0.74.2_events.patch37
3 files changed, 72 insertions, 47 deletions
diff --git a/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch b/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch
deleted file mode 100644
index 98b4508f519f..000000000000
--- a/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/include/dos_inc.h 2011-04-28 08:46:04.505011354 +0200
-+++ b/include/dos_inc.h 2011-04-28 08:46:27.104408178 +0200
-@@ -21,6 +21,7 @@
- #ifndef DOSBOX_DOS_INC_H
- #define DOSBOX_DOS_INC_H
-
-+#include <cstddef>
- #ifndef DOSBOX_DOS_SYSTEM_H
- #include "dos_system.h"
- #endif
diff --git a/games-emulation/dosbox/files/dosbox-0.74-ncurses.patch b/games-emulation/dosbox/files/dosbox-0.74-ncurses.patch
new file mode 100644
index 000000000000..dd7016f8c926
--- /dev/null
+++ b/games-emulation/dosbox/files/dosbox-0.74-ncurses.patch
@@ -0,0 +1,72 @@
+https://sourceforge.net/p/dosbox/patches/286/
+
+--- a/configure.ac 2019-11-12 17:55:51.000000000 +0000
++++ b/configure.ac 2020-01-02 21:26:27.551856431 +0000
+@@ -235,36 +235,38 @@
+ #Features to enable/disable
+ AH_TEMPLATE(C_DEBUG,[Define to 1 to enable internal debugger, requires libcurses])
+ AH_TEMPLATE(C_HEAVY_DEBUG,[Define to 1 to enable heavy debugging, also have to enable C_DEBUG])
+-AC_ARG_ENABLE(debug,AC_HELP_STRING([--enable-debug],[Enable debug mode]),[
+- AC_CHECK_HEADER(curses.h,have_curses_h=yes,)
+- AC_CHECK_LIB(curses, initscr, have_curses_lib=yes, , )
+- AC_CHECK_LIB(ncurses, initscr, have_ncurses_lib=yes, , )
+- AC_CHECK_LIB(pdcurses, initscr, have_pdcurses_lib=yes, , )
++AC_ARG_ENABLE(debug,AC_HELP_STRING([--enable-debug],[Enable debug mode]),,enable_debug=no)
++AC_MSG_CHECKING(whether debug will be enabled)
++
++if test x$enable_debug = xno; then
++ AC_MSG_RESULT(no)
++else
++ AC_MSG_RESULT(yes)
+
+- if test x$enable_debug = xno; then
+- AC_MSG_RESULT([Debugger not enabled])
+- elif test x$have_ncurses_lib = xyes -a x$have_curses_h = xyes ; then
+- LIBS="$LIBS -lncurses"
+- AC_DEFINE(C_DEBUG,1)
+- if test x$enable_debug = xheavy ; then
+- AC_DEFINE(C_HEAVY_DEBUG,1)
+- fi
+- elif test x$have_curses_lib = xyes -a x$have_curses_h = xyes ; then
+- LIBS="$LIBS -lcurses"
+- AC_DEFINE(C_DEBUG,1)
+- if test x$enable_debug = xheavy ; then
+- AC_DEFINE(C_HEAVY_DEBUG,1)
+- fi
+- elif test x$have_pdcurses_lib = xyes -a x$have_curses_h = xyes ; then
+- LIBS="$LIBS -lpdcurses"
+- AC_DEFINE(C_DEBUG,1)
+- if test x$enable_debug = xheavy ; then
+- AC_DEFINE(C_HEAVY_DEBUG,1)
+- fi
+- else
+- AC_MSG_ERROR([Can't find curses, which is required for debug mode])
+- fi
+-],)
++ PKG_CHECK_MODULES(NCURSES, ncurses, [
++ LIBS="$LIBS $NCURSES_LIBS"; CFLAGS="$CFLAGS $NCURSES_CFLAGS"
++ ], [
++ AC_CHECK_HEADER(curses.h,have_curses_h=yes,)
++ AC_CHECK_LIB(curses, initscr, have_curses_lib=yes, , )
++ AC_CHECK_LIB(ncurses, initscr, have_ncurses_lib=yes, , )
++ AC_CHECK_LIB(pdcurses, initscr, have_pdcurses_lib=yes, , )
++
++ if test x$have_ncurses_lib = xyes -a x$have_curses_h = xyes ; then
++ LIBS="$LIBS -lncurses"
++ elif test x$have_curses_lib = xyes -a x$have_curses_h = xyes ; then
++ LIBS="$LIBS -lcurses"
++ elif test x$have_pdcurses_lib = xyes -a x$have_curses_h = xyes ; then
++ LIBS="$LIBS -lpdcurses"
++ else
++ AC_MSG_ERROR([Can't find curses, which is required for debug mode])
++ fi
++ ])
++
++ AC_DEFINE(C_DEBUG,1)
++ if test x$enable_debug = xheavy; then
++ AC_DEFINE(C_HEAVY_DEBUG,1)
++ fi
++fi
+
+ AH_TEMPLATE(C_CORE_INLINE,[Define to 1 to use inlined memory functions in cpu core])
+ AC_ARG_ENABLE(core-inline,AC_HELP_STRING([--disable-core-inline],[Disable inlined memory handling in CPU Core]),,enable_core_inline=yes)
diff --git a/games-emulation/dosbox/files/dosbox-0.74.2_events.patch b/games-emulation/dosbox/files/dosbox-0.74.2_events.patch
deleted file mode 100644
index fee09a65a4ce..000000000000
--- a/games-emulation/dosbox/files/dosbox-0.74.2_events.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Index: src/gui/sdlmain.cpp
-===================================================================
---- a/src/gui/sdlmain.cpp (revision 4177)
-+++ b/src/gui/sdlmain.cpp (working copy)
-@@ -1426,6 +1426,12 @@
- #define DB_POLLSKIP 1
- #endif
-
-+#if defined(LINUX)
-+#define SDL_XORG_FIX 1
-+#else
-+#define SDL_XORG_FIX 0
-+#endif
-+
- void GFX_Events() {
- //Don't poll too often. This can be heavy on the OS, especially Macs.
- //In idle mode 3000-4000 polls are done per second without this check.
-@@ -1449,6 +1455,19 @@
- }
- #endif
- while (SDL_PollEvent(&event)) {
-+#if SDL_XORG_FIX
-+ // Special code for broken SDL with Xorg 1.20.1, where pairs of inputfocus gain and loss events are generated
-+ // when locking the mouse in windowed mode.
-+ if (event.type == SDL_ACTIVEEVENT && event.active.state == SDL_APPINPUTFOCUS && event.active.gain == 0) {
-+ SDL_Event test; //Check if the next event would undo this one.
-+ if (SDL_PeepEvents(&test,1,SDL_PEEKEVENT,SDL_ACTIVEEVENTMASK) == 1 && test.active.state == SDL_APPINPUTFOCUS && test.active.gain == 1) {
-+ // Skip both events.
-+ SDL_PeepEvents(&test,1,SDL_GETEVENT,SDL_ACTIVEEVENTMASK);
-+ continue;
-+ }
-+ }
-+#endif
-+
- switch (event.type) {
- case SDL_ACTIVEEVENT:
- if (event.active.state & SDL_APPINPUTFOCUS) {