summaryrefslogtreecommitdiff
path: root/games-emulation/dosbox/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /games-emulation/dosbox/files
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'games-emulation/dosbox/files')
-rw-r--r--games-emulation/dosbox/files/dosbox-0.75-ncurses.patch78
1 files changed, 78 insertions, 0 deletions
diff --git a/games-emulation/dosbox/files/dosbox-0.75-ncurses.patch b/games-emulation/dosbox/files/dosbox-0.75-ncurses.patch
new file mode 100644
index 000000000000..67c23c70532a
--- /dev/null
+++ b/games-emulation/dosbox/files/dosbox-0.75-ncurses.patch
@@ -0,0 +1,78 @@
+https://sourceforge.net/p/dosbox/patches/286/
+
+--- a/configure.ac 2019-11-12 17:55:51.000000000 +0000
++++ b/configure.ac 2020-01-02 21:26:27.551856431 +0000
+@@ -235,39 +235,41 @@
+ #Features to enable/disable
+ AH_TEMPLATE(C_DEBUG,[Define to 1 to enable internal debugger, requires libcurses])
+ AH_TEMPLATE(C_HEAVY_DEBUG,[Define to 1 to enable heavy debugging, also have to enable C_DEBUG])
+-AC_ARG_ENABLE(debug,AC_HELP_STRING([--enable-debug],[Enable debug mode]),[
+- AC_CHECK_HEADER(curses.h,have_curses_h=yes,)
+- AC_CHECK_LIB(curses, initscr, have_curses_lib=yes, , )
+- AC_CHECK_LIB(ncurses, initscr, have_ncurses_lib=yes, , )
+- AC_CHECK_LIB(pdcurses, initscr, have_pdcurses_lib=yes, , )
++AC_ARG_ENABLE(debug,AC_HELP_STRING([--enable-debug],[Enable debug mode]),,enable_debug=no)
++AC_MSG_CHECKING(whether debug will be enabled)
++
++if test x$enable_debug = xno; then
++ AC_MSG_RESULT(no)
++else
++ AC_MSG_RESULT(yes)
+
+- if test x$enable_debug = xno; then
+- AC_MSG_RESULT([Debugger not enabled])
+- elif test x$have_ncurses_lib = xyes -a x$have_curses_h = xyes ; then
+- LIBS="$LIBS -lncurses"
+- if test x$host = xi386-pc-os2-emx ; then
+- LIBS="$LIBS -ltinfo"
+- fi
+- AC_DEFINE(C_DEBUG,1)
+- if test x$enable_debug = xheavy ; then
+- AC_DEFINE(C_HEAVY_DEBUG,1)
+- fi
+- elif test x$have_curses_lib = xyes -a x$have_curses_h = xyes ; then
+- LIBS="$LIBS -lcurses"
+- AC_DEFINE(C_DEBUG,1)
+- if test x$enable_debug = xheavy ; then
+- AC_DEFINE(C_HEAVY_DEBUG,1)
+- fi
+- elif test x$have_pdcurses_lib = xyes -a x$have_curses_h = xyes ; then
+- LIBS="$LIBS -lpdcurses"
+- AC_DEFINE(C_DEBUG,1)
+- if test x$enable_debug = xheavy ; then
+- AC_DEFINE(C_HEAVY_DEBUG,1)
+- fi
+- else
+- AC_MSG_ERROR([Can't find curses, which is required for debug mode])
+- fi
+-],)
++ PKG_CHECK_MODULES(NCURSES, ncurses, [
++ LIBS="$LIBS $NCURSES_LIBS"; CFLAGS="$CFLAGS $NCURSES_CFLAGS"
++ ], [
++ AC_CHECK_HEADER(curses.h,have_curses_h=yes,)
++ AC_CHECK_LIB(curses, initscr, have_curses_lib=yes, , )
++ AC_CHECK_LIB(ncurses, initscr, have_ncurses_lib=yes, , )
++ AC_CHECK_LIB(pdcurses, initscr, have_pdcurses_lib=yes, , )
++
++ if test x$have_ncurses_lib = xyes -a x$have_curses_h = xyes ; then
++ LIBS="$LIBS -lncurses"
++ if test x$host = xi386-pc-os2-emx ; then
++ LIBS="$LIBS -ltinfo"
++ fi
++ elif test x$have_curses_lib = xyes -a x$have_curses_h = xyes ; then
++ LIBS="$LIBS -lcurses"
++ elif test x$have_pdcurses_lib = xyes -a x$have_curses_h = xyes ; then
++ LIBS="$LIBS -lpdcurses"
++ else
++ AC_MSG_ERROR([Can't find curses, which is required for debug mode])
++ fi
++ ])
++
++ AC_DEFINE(C_DEBUG,1)
++ if test x$enable_debug = xheavy; then
++ AC_DEFINE(C_HEAVY_DEBUG,1)
++ fi
++fi
+
+ AH_TEMPLATE(C_CORE_INLINE,[Define to 1 to use inlined memory functions in cpu core])
+ AC_ARG_ENABLE(core-inline,AC_HELP_STRING([--disable-core-inline],[Disable inlined memory handling in CPU Core]),,enable_core_inline=yes)