summaryrefslogtreecommitdiff
path: root/games-emulation/fbzx/fbzx-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-emulation/fbzx/fbzx-3.0.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-emulation/fbzx/fbzx-3.0.0.ebuild')
-rw-r--r--games-emulation/fbzx/fbzx-3.0.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-emulation/fbzx/fbzx-3.0.0.ebuild b/games-emulation/fbzx/fbzx-3.0.0.ebuild
new file mode 100644
index 000000000000..257a97eb1774
--- /dev/null
+++ b/games-emulation/fbzx/fbzx-3.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A Sinclair Spectrum emulator, designed to work at full screen using the FrameBuffer"
+HOMEPAGE="https://github.com/rastersoft/fbzx"
+SRC_URI="https://github.com/rastersoft/fbzx/archive/3.0.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[video]
+ media-sound/pulseaudio
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e "s|/usr/share/|${GAMES_DATADIR}/${PN}/|g" src/llscreen.cpp || die
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_install() {
+ dogamesbin src/fbzx
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data/{keymap.bmp,spectrum-roms}
+ dodoc AMSTRAD CAPABILITIES FAQ PORTING README* TODO VERSIONS
+ doicon data/fbzx.svg
+ make_desktop_entry fbzx FBZX
+ prepgamesdirs
+}