summaryrefslogtreecommitdiff
path: root/games-emulation/gambatte
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-emulation/gambatte
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/gambatte')
-rw-r--r--games-emulation/gambatte/Manifest3
-rw-r--r--games-emulation/gambatte/gambatte-0.5.0_p20131102-r2.ebuild74
-rw-r--r--games-emulation/gambatte/metadata.xml11
3 files changed, 88 insertions, 0 deletions
diff --git a/games-emulation/gambatte/Manifest b/games-emulation/gambatte/Manifest
new file mode 100644
index 000000000000..a5191aaacb28
--- /dev/null
+++ b/games-emulation/gambatte/Manifest
@@ -0,0 +1,3 @@
+DIST gambatte-0.5.0_p20131102.tar.xz 353212 BLAKE2B ad17289f29a00230d7ccec2825d6487ed994a6148a931254a9d5c941c5dbb643c5eb4dbd9f43decfcb86fb693f82358e795a4912c4d40258b27b0d8611961ec1 SHA512 9f27af85d2fceb128231eb3e5bf2806a1773c575990296f37eb3c0a14bca5c72f7f161cdf77f710f4ff85b2b3266db9ba098e5ef6772bc5bf7b2c97b8281999b
+EBUILD gambatte-0.5.0_p20131102-r2.ebuild 1624 BLAKE2B 59fd76fbfc8afd9aaa57f77d3aca89277e0bdf96c5bfda0f098845b4e3b6d47ec629d0a8b1fc8e84583dbf8868c23772a0a581e65024d04625a0342d4a2ecd88 SHA512 ee9838bc274b9c6682af17b8c185d81d7ec1b176eec3d386e3da6e489489b3f5cc9b74d5c3aaa840ce7047bd83e52b87f4304a847437cf69d9a21a6d7a3bfb77
+MISC metadata.xml 331 BLAKE2B b739e6db5361a25503fed526b7417578fff92612b1ca90c4a6e8578bd678f3b3b69736238a9ad882a654c7c9bd66b8d1ac296899129610b23ab96918067012d8 SHA512 c46ee0b944bbf88420eb47c11f60d00a6516fe2bb28b5078e8f11857636f16381969cac9edb98d554d07d0894c224817e12560410092ca532da036e697433b1a
diff --git a/games-emulation/gambatte/gambatte-0.5.0_p20131102-r2.ebuild b/games-emulation/gambatte/gambatte-0.5.0_p20131102-r2.ebuild
new file mode 100644
index 000000000000..57ce854affa0
--- /dev/null
+++ b/games-emulation/gambatte/gambatte-0.5.0_p20131102-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit scons-utils
+
+DESCRIPTION="An accuracy-focused Gameboy / Gameboy Color emulator"
+HOMEPAGE="https://sourceforge.net/projects/gambatte"
+SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[X,sound,joystick,video]
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+fix_scons() {
+ local i
+ for i; do
+ cat >> $i << END
+import os
+import SCons.Util
+
+if os.environ.has_key('AR'):
+ env['AR'] = os.environ['AR']
+if os.environ.has_key('RANLIB'):
+ env['RANLIB'] = os.environ['RANLIB']
+if os.environ.has_key('CC'):
+ env['CC'] = os.environ['CC']
+if os.environ.has_key('CFLAGS'):
+ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
+if os.environ.has_key('CXX'):
+ env['CXX'] = os.environ['CXX']
+if os.environ.has_key('CXXFLAGS'):
+ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
+if os.environ.has_key('CPPFLAGS'):
+ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CPPFLAGS'])
+if os.environ.has_key('LDFLAGS'):
+ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+END
+ done
+}
+
+src_prepare() {
+ default
+
+ # Fix zlib/minizip build error
+ sed -i \
+ -e '1i#define OF(x) x' \
+ libgambatte/src/file/unzip/{unzip,ioapi}.h \
+ || die "sed iompi.h failed"
+
+ fix_scons {gambatte_sdl,libgambatte}/SConstruct
+}
+
+src_compile() {
+ # build core library
+ cd "${S}"/libgambatte || die
+ escons
+
+ # build sdl frontend
+ cd "${S}"/gambatte_sdl || die
+ escons
+}
+
+src_install() {
+ dobin gambatte_sdl/gambatte_sdl
+ einstalldocs
+}
diff --git a/games-emulation/gambatte/metadata.xml b/games-emulation/gambatte/metadata.xml
new file mode 100644
index 000000000000..a2f679865cad
--- /dev/null
+++ b/games-emulation/gambatte/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">gambatte</remote-id>
+ </upstream>
+</pkgmetadata>