summaryrefslogtreecommitdiff
path: root/games-emulation/generator/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /games-emulation/generator/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'games-emulation/generator/files')
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-autoconf.patch (renamed from games-emulation/generator/files/generator-0.35_p4-configure.patch)16
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-automake.patch26
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-gcc-9.patch22
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-gcc.patch53
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-inline.patch12
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-underlink.patch11
6 files changed, 91 insertions, 49 deletions
diff --git a/games-emulation/generator/files/generator-0.35_p4-configure.patch b/games-emulation/generator/files/generator-0.35_p4-autoconf.patch
index a918c4a97113..ccc9655a2a72 100644
--- a/games-emulation/generator/files/generator-0.35_p4-configure.patch
+++ b/games-emulation/generator/files/generator-0.35_p4-autoconf.patch
@@ -1,5 +1,5 @@
---- a/configure.ac.original 2008-03-17 13:07:48.000000000 -0400
-+++ b/configure.ac 2008-03-17 13:08:03.000000000 -0400
+--- a/configure.ac
++++ b/configure.ac
@@ -28,15 +28,12 @@
AC_ARG_WITH(tcltk,
AS_HELP_STRING(--with-tcltk,Create tcltk version),
@@ -68,7 +68,15 @@
AC_CHECK_LIB(jpeg, jpeg_start_compress,
[ MY_LIBS="-ljpeg $MY_LIBS"; AC_DEFINE(JPEG, 1, [JPEG features]) ])
-@@ -272,14 +225,7 @@
+@@ -259,6 +212,7 @@
+ AC_PROG_CC
+ AC_PROG_CPP
+ AC_PROG_RANLIB
++ AM_PROG_AR
+ AC_PROG_MAKE_SET
+ AC_ISC_POSIX
+ AC_PROG_INSTALL
+@@ -272,14 +226,7 @@
AC_PATH_XTRA
@@ -84,7 +92,7 @@
MY_SUBDIRS="gtkopts $MY_SUBDIRS"
AM_PATH_SDL(1.2.6,,AC_MSG_ERROR(Generator needs sdk 1.2.6 or later))
-@@ -305,6 +251,7 @@
+@@ -305,6 +252,7 @@
AC_CHECK_SIZEOF(unsigned long, 4)
AC_CHECK_SIZEOF(unsigned long long, 8)
AC_CHECK_HEADERS(sys/param.h)
diff --git a/games-emulation/generator/files/generator-0.35_p4-automake.patch b/games-emulation/generator/files/generator-0.35_p4-automake.patch
new file mode 100644
index 000000000000..e04ed94b9be8
--- /dev/null
+++ b/games-emulation/generator/files/generator-0.35_p4-automake.patch
@@ -0,0 +1,26 @@
+--- a/cpu68k/Makefile.am
++++ b/cpu68k/Makefile.am
+@@ -29,6 +29,7 @@
+
+ gen68k_SOURCES = gen68k.c tab68k.c
+ gen68k_DEPENDENCIES = def68k-iibs.h
++BUILT_SOURCES = def68k-iibs.h
+
+ noinst_LIBRARIES = lib68k.a
+ lib68k_a_SOURCES = cpu68k-0.c cpu68k-1.c cpu68k-2.c cpu68k-3.c \
+--- a/main/Makefile.am
++++ b/main/Makefile.am
+@@ -3,11 +3,11 @@
+ INCLUDES = -I../hdr -I. -I../cpu68k -I../ym2612 -I../raze -I../cmz80 \
+ -I../sn76496 -I../gtkopts \
+ -DFNAME_TCLSCRIPT=\"${datadir}/generator/gen.tcl\" \
+- @GTK_CFLAGS@ @SDL_CFLAGS@
++ @SDL_CFLAGS@
+ bin_PROGRAMS = @PROGRAM@
+ EXTRA_PROGRAMS = generator-svgalib generator-tcltk generator-allegro \
+ generator-gtk generator-sdl
+-LDADD = ../cpu68k/lib68k.a ../ym2612/libym2612.a @MY_LIBS@ \
++LDADD = ../cpu68k/lib68k.a ../ym2612/libym2612.a @MY_LIBS@ -lm \
+ ../sn76496/libsn76496.a
+
+ ## this should be generator_tcltk_DATA but it won't let me do that
diff --git a/games-emulation/generator/files/generator-0.35_p4-gcc-9.patch b/games-emulation/generator/files/generator-0.35_p4-gcc-9.patch
deleted file mode 100644
index 7b8eeafb7154..000000000000
--- a/games-emulation/generator/files/generator-0.35_p4-gcc-9.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://bugs.gentoo.org/698944
-
---- a/main/vdp.c
-+++ b/main/vdp.c
-@@ -87,7 +87,7 @@ void vdp_describe(void);
- void vdp_eventinit(void);
- void vdp_layer_simple(unsigned int layer, unsigned int priority,
- uint8 *fielddata, unsigned int lineoffset);
--inline void vdp_plotcell(uint8 *patloc, uint8 palette, uint8 flags,
-+static void vdp_plotcell(uint8 *patloc, uint8 palette, uint8 flags,
- uint8 *cellloc, unsigned int lineoffset);
- void vdp_sprites(unsigned int line, uint8 *pridata, uint8 *outdata);
- int vdp_sprite_simple(unsigned int priority, uint8 *framedata,
-@@ -1733,7 +1733,7 @@ void vdp_endfield(void)
- vdp_event_endline); */
- }
-
--inline void vdp_plotcell(uint8 *patloc, uint8 palette, uint8 flags,
-+static void vdp_plotcell(uint8 *patloc, uint8 palette, uint8 flags,
- uint8 *cellloc, unsigned int lineoffset)
- {
- int y, x;
diff --git a/games-emulation/generator/files/generator-0.35_p4-gcc.patch b/games-emulation/generator/files/generator-0.35_p4-gcc.patch
new file mode 100644
index 000000000000..e82512f0e3fb
--- /dev/null
+++ b/games-emulation/generator/files/generator-0.35_p4-gcc.patch
@@ -0,0 +1,53 @@
+--- a/hdr/cpuz80.h
++++ b/hdr/cpuz80.h
+@@ -5,7 +5,7 @@
+ # include "raze.h"
+ #else
+ # include "cmz80.h"
+-CONTEXTMZ80 cpuz80_z80; /* extern'd for save state code */
++extern CONTEXTMZ80 cpuz80_z80; /* extern'd for save state code */
+ #endif
+
+ #define LEN_SRAM 0x2000
+--- a/main/event.c
++++ b/main/event.c
+@@ -15,7 +15,7 @@
+
+ /* time for next event - update vdp_event - return when to call again */
+
+-inline void event_nextevent(void)
++void event_nextevent(void)
+ {
+ /* call this when it *is* time for the next event as dictated by vdp_event,
+ so we switch on it and update vdp_event at the same time */
+--- a/main/vdp.c
++++ b/main/vdp.c
+@@ -87,7 +87,7 @@
+ void vdp_eventinit(void);
+ void vdp_layer_simple(unsigned int layer, unsigned int priority,
+ uint8 *fielddata, unsigned int lineoffset);
+-inline void vdp_plotcell(uint8 *patloc, uint8 palette, uint8 flags,
++static void vdp_plotcell(uint8 *patloc, uint8 palette, uint8 flags,
+ uint8 *cellloc, unsigned int lineoffset);
+ void vdp_sprites(unsigned int line, uint8 *pridata, uint8 *outdata);
+ int vdp_sprite_simple(unsigned int priority, uint8 *framedata,
+@@ -1733,7 +1733,7 @@
+ vdp_event_endline); */
+ }
+
+-inline void vdp_plotcell(uint8 *patloc, uint8 palette, uint8 flags,
++static void vdp_plotcell(uint8 *patloc, uint8 palette, uint8 flags,
+ uint8 *cellloc, unsigned int lineoffset)
+ {
+ int y, x;
+--- a/ym2612/support.h
++++ b/ym2612/support.h
+@@ -3,7 +3,7 @@
+ #include "config.h"
+
+ #define errorlog 0
+-#define INLINE inline
++#define INLINE
+ #define HAS_YM2612 1
+ #define YM2612UpdateRequest(x)
+ #define AY8910_set_clock(chip,clock)
diff --git a/games-emulation/generator/files/generator-0.35_p4-inline.patch b/games-emulation/generator/files/generator-0.35_p4-inline.patch
deleted file mode 100644
index e7f09fa3689c..000000000000
--- a/games-emulation/generator/files/generator-0.35_p4-inline.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur generator-0.35-cbiere-r4/ym2612/support.h generator-0.35-cbiere-r4-patched/ym2612/support.h
---- generator-0.35-cbiere-r4/ym2612/support.h 2005-08-27 05:12:29.000000000 -0400
-+++ generator-0.35-cbiere-r4-patched/ym2612/support.h 2018-03-26 11:49:36.000000000 -0400
-@@ -3,7 +3,7 @@
- #include "config.h"
-
- #define errorlog 0
--#define INLINE inline
-+#define INLINE
- #define HAS_YM2612 1
- #define YM2612UpdateRequest(x)
- #define AY8910_set_clock(chip,clock)
diff --git a/games-emulation/generator/files/generator-0.35_p4-underlink.patch b/games-emulation/generator/files/generator-0.35_p4-underlink.patch
deleted file mode 100644
index b350e8b8a334..000000000000
--- a/games-emulation/generator/files/generator-0.35_p4-underlink.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/main/Makefile.am.old 2011-06-20 21:35:25.832460030 +0200
-+++ b/main/Makefile.am 2011-06-20 21:36:29.490503981 +0200
-@@ -7,7 +7,7 @@
- bin_PROGRAMS = @PROGRAM@
- EXTRA_PROGRAMS = generator-svgalib generator-tcltk generator-allegro \
- generator-gtk generator-sdl
--LDADD = ../cpu68k/lib68k.a ../ym2612/libym2612.a @MY_LIBS@ \
-+LDADD = ../cpu68k/lib68k.a ../ym2612/libym2612.a @MY_LIBS@ -lm \
- ../sn76496/libsn76496.a
-
- ## this should be generator_tcltk_DATA but it won't let me do that