summaryrefslogtreecommitdiff
path: root/games-emulation/gngeo/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-emulation/gngeo/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-emulation/gngeo/files')
-rw-r--r--games-emulation/gngeo/files/gngeo-0.8-cflags.patch41
-rw-r--r--games-emulation/gngeo/files/gngeo-0.8-concurrentMake.patch16
-rw-r--r--games-emulation/gngeo/files/gngeo-0.8-execstacks.patch105
-rw-r--r--games-emulation/gngeo/files/gngeo-0.8-zlib.patch9
4 files changed, 171 insertions, 0 deletions
diff --git a/games-emulation/gngeo/files/gngeo-0.8-cflags.patch b/games-emulation/gngeo/files/gngeo-0.8-cflags.patch
new file mode 100644
index 000000000000..1a4892abae9e
--- /dev/null
+++ b/games-emulation/gngeo/files/gngeo-0.8-cflags.patch
@@ -0,0 +1,41 @@
+--- configure.in.orig 2016-03-31 04:15:45.913917791 -0400
++++ configure.in 2016-03-31 04:16:23.447607551 -0400
+@@ -236,20 +236,12 @@
+ AC_DEFINE(PROCESSOR_INTEL, 1, [Define if you have an x86 processor])
+ ALIGNLONGS=0
+ proc_i386=true
+- CFLAGS="$CFLAGS -O3 -fstrength-reduce -frerun-loop-opt -Wall -Wno-unused -funroll-loops \
+- -ffast-math -falign-functions=2 -falign-jumps=2 -fexpensive-optimizations \
+- -falign-loops=2 -fschedule-insns2 -malign-double -fomit-frame-pointer -g \
+- -fno-strict-aliasing -pipe -mtune=$target_cpu -DCPU=$target_cpu"
+ ;;
+ x86_64)
+ AC_MSG_RESULT(Turning on x86_64 processor optimisations)
+ AC_DEFINE(PROCESSOR_ADM64, 1, [Define if you have an x86_64 processor])
+ ALIGNLONGS=0
+ proc_x64=true
+- CFLAGS="$CFLAGS -O3 -fstrength-reduce -frerun-loop-opt -Wall -Wno-unused -funroll-loops \
+- -ffast-math -fexpensive-optimizations \
+- -malign-double -fomit-frame-pointer -g \
+- -fno-strict-aliasing -pipe -DCPU=$target_cpu"
+ ;;
+ sparc*) AC_MSG_RESULT(Turning on sparc processor optimisations)
+ AC_DEFINE(PROCESSOR_SPARC, 1, [Define if you have a sparc processor])
+@@ -258,8 +250,6 @@
+ if test $target_cpu = sparc64 && test $CC_MAJOR -ge 3 ; then
+ CFLAGS="$CFLAGS -mcpu=v9"
+ fi
+- CFLAGS="$CFLAGS -O3 -Wall -Wno-unused -funroll-loops \
+- -ffast-math -fomit-frame-pointer -g"
+ ;;
+ arm) AC_MSG_RESULT(Turning on arm processor optimisations)
+ AC_DEFINE(PROCESSOR_ARM, 1, [Define if you have an ARM processor])
+@@ -273,8 +263,6 @@
+ *) AC_MSG_RESULT(Processor type unknown - Use generic optimisations)
+ ALIGNLONGS=1
+ optimum=no
+- CFLAGS="$CFLAGS -O3 -Wall -Wno-unused -funroll-loops \
+- -ffast-math -g"
+ ;;
+ esac
+
diff --git a/games-emulation/gngeo/files/gngeo-0.8-concurrentMake.patch b/games-emulation/gngeo/files/gngeo-0.8-concurrentMake.patch
new file mode 100644
index 000000000000..1afc182c0988
--- /dev/null
+++ b/games-emulation/gngeo/files/gngeo-0.8-concurrentMake.patch
@@ -0,0 +1,16 @@
+--- src/generator68k/Makefile.am.orig 2015-01-23 18:37:37.998723294 -0500
++++ src/generator68k/Makefile.am 2015-01-23 18:38:39.995391133 -0500
+@@ -71,9 +71,12 @@
+
+ #def68k : def68k.c
+ # gcc def68k.c tab68k.c -o def68k -I .. -I ../.. -I . `sdl-config --cflags`
+-def68k.o gen68k.o tab68k2.o : %.o : %.c
++def68k.o tab68k2.o : %.o : %.c
+ $(gcc_build_verbose)$(CC_FOR_BUILD) -c $< -o $@ -I .. -I ../.. -I . `sdl-config --cflags`
+
++gen68k.o: gen68k.c def68k-iibs.h
++ $(CC_FOR_BUILD) -c $< -o $@ -I .. -I ../.. -I . `sdl-config --cflags`
++
+ def68k : def68k.o tab68k2.o
+ $(gcc_build_verbose)$(CC_FOR_BUILD) def68k.o tab68k2.o -o $@
+
diff --git a/games-emulation/gngeo/files/gngeo-0.8-execstacks.patch b/games-emulation/gngeo/files/gngeo-0.8-execstacks.patch
new file mode 100644
index 000000000000..17c576b7d634
--- /dev/null
+++ b/games-emulation/gngeo/files/gngeo-0.8-execstacks.patch
@@ -0,0 +1,105 @@
+--- src/effect/2xsaimmx.asm
++++ src/effect/2xsaimmx.asm
+@@ -2107,3 +2107,7 @@
+ final1b resb 8
+ final2a resb 8
+ final2b resb 8
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- src/effect/effect_i386.asm
++++ src/effect/effect_i386.asm
+@@ -88,3 +88,7 @@
+ emms
+
+ endproc
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- src/effect/hq2x16.asm
++++ src/effect/hq2x16.asm
+@@ -1935,3 +1935,7 @@
+ dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
+ dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
+
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- src/effect/hq3x16.asm
++++ src/effect/hq3x16.asm
+@@ -2520,3 +2520,7 @@
+ dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
+ dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
+
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- src/memcpy.S
++++ src/memcpy.S
+@@ -495,4 +495,8 @@
+
+ Lmemcpy_bsrcul1l4:
+ add r1, r1, #1
+-b Lmemcpy_bl4
+\ No newline at end of file
++b Lmemcpy_bl4
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",@progbits
++#endif
+--- src/raze/Makefile.am
++++ src/raze/Makefile.am
+@@ -20,7 +20,7 @@
+ $(srcdir)/strip_ $< $@
+
+ raze2.asm: raze.asmu raze.incu raze.regu
+- nasm -w+orphan-labels -I $(srcdir)/ -e $< -o $@
++ nasm -w+orphan-labels -f elf -I $(srcdir)/ -e $< -o $@
+
+ # This assembles the file, once it's been pre-processed
+ raze.o: raze2.asm
+--- src/raze/raze.asm
++++ src/raze/raze.asm
+@@ -4259,3 +4259,6 @@
+
+ ;- the end ------------------------------------------------------------------;
+
++%ifidn ___OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- src/screen_i386.asm
++++ src/screen_i386.asm
+@@ -96,3 +96,6 @@
+ endproc
+
+
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- src/star/star.c
++++ src/star/star.c
+@@ -2431,6 +2431,10 @@
+ */
+ static void suffixes(void) {
+ emit("end\n");
++
++ emit("%%ifidn ___OUTPUT_FORMAT__,elf\n");
++ emit("section .note.GNU-stack noalloc noexec nowrite progbits\n");
++ emit("%%endif\n");
+ }
+
+ /****************************************************************************
+--- src/video_i386.asm
++++ src/video_i386.asm
+@@ -86,3 +86,7 @@
+
+ popa
+ endproc
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
diff --git a/games-emulation/gngeo/files/gngeo-0.8-zlib.patch b/games-emulation/gngeo/files/gngeo-0.8-zlib.patch
new file mode 100644
index 000000000000..9aa4a6b5f479
--- /dev/null
+++ b/games-emulation/gngeo/files/gngeo-0.8-zlib.patch
@@ -0,0 +1,9 @@
+diff -ru gngeo-0.8.orig/configure.in gngeo-0.8/configure.in
+--- gngeo-0.8.orig/configure.in 2012-11-15 17:57:57.849578009 -0500
++++ gngeo-0.8/configure.in 2012-11-15 18:19:55.305923094 -0500
+@@ -95,6 +95,7 @@
+ #AC_SUBST(LIBOBJS)
+ AC_CHECK_LIB([m], [acos])
+ AC_CHECK_LIB([z], [inflate])
++AC_CHECK_LIB([minizip], [unzReadCurrentFile])
+