summaryrefslogtreecommitdiff
path: root/games-emulation/gngeo/gngeo-0.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
commit2f8db31405fac68eea6f7257d58529243815033b (patch)
tree54259cc8988a98a10586fc0496b1f3501cd1e2a1 /games-emulation/gngeo/gngeo-0.8-r1.ebuild
parenta4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (diff)
gentoo resync : 30.04.2018
Diffstat (limited to 'games-emulation/gngeo/gngeo-0.8-r1.ebuild')
-rw-r--r--games-emulation/gngeo/gngeo-0.8-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-emulation/gngeo/gngeo-0.8-r1.ebuild b/games-emulation/gngeo/gngeo-0.8-r1.ebuild
new file mode 100644
index 000000000000..3e7f2be86fc0
--- /dev/null
+++ b/games-emulation/gngeo/gngeo-0.8-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop flag-o-matic
+
+DESCRIPTION="A NeoGeo emulator"
+HOMEPAGE="https://code.google.com/p/gngeo/"
+SRC_URI="https://gngeo.googlecode.com/files/${P}.tar.gz
+ https://storage.googleapis.com/google-code-archive/v2/code.google.com/gngeo/logo.png -> ${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/libsdl[joystick,opengl,sound,video]
+ sys-libs/zlib[minizip]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}"/${P}-execstacks.patch \
+ "${FILESDIR}"/${P}-zlib.patch \
+ "${FILESDIR}"/${P}-concurrentMake.patch \
+ "${FILESDIR}"/${P}-cflags.patch
+ mv configure.in configure.ac || die
+ eautoreconf
+ append-cflags -std=gnu89 # build with gcc5 (bug #571056)
+}
+
+src_configure() {
+ econf --disable-i386asm
+}
+
+src_install() {
+ DOCS=( AUTHORS FAQ NEWS README* TODO sample_gngeorc )
+ default
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN}
+}