summaryrefslogtreecommitdiff
path: root/games-emulation/mamory/mamory-0.2.25-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
commit2f8db31405fac68eea6f7257d58529243815033b (patch)
tree54259cc8988a98a10586fc0496b1f3501cd1e2a1 /games-emulation/mamory/mamory-0.2.25-r1.ebuild
parenta4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (diff)
gentoo resync : 30.04.2018
Diffstat (limited to 'games-emulation/mamory/mamory-0.2.25-r1.ebuild')
-rw-r--r--games-emulation/mamory/mamory-0.2.25-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-emulation/mamory/mamory-0.2.25-r1.ebuild b/games-emulation/mamory/mamory-0.2.25-r1.ebuild
new file mode 100644
index 000000000000..cccd915c6f27
--- /dev/null
+++ b/games-emulation/mamory/mamory-0.2.25-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic
+
+DESCRIPTION="ROM management tools and library"
+HOMEPAGE="http://mamory.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/expat"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ # Make sure the system expat is used
+ sed -i \
+ -e 's/#ifdef.*SYSEXPAT/#if 1/' \
+ mamory/amlxml.c mamory/amlxml.h || die
+
+ # Remove hardcoded CFLAGS options
+ sed -i \
+ -e '/AC_ARG_ENABLE(debug,/ {N;N;N;d}' \
+ configure.ac || die
+
+ # Make it possible for eautoreconf to fix fPIC etc.
+ sed -i \
+ -e '/libcommon_la_LDFLAGS= -static/d' \
+ common/Makefile.am || die
+
+ AT_M4DIR="config" eautoreconf
+ append-cflags -std=gnu89 # build with gcc5 (bug #570500)
+}
+
+src_configure() {
+ econf \
+ --includedir=/usr/include \
+ --disable-static
+}
+
+src_install() {
+ HTML_DOCS="DOCS/mamory.html" default
+ find "${D}" -name '*.la' -delete || die
+}