summaryrefslogtreecommitdiff
path: root/games-emulation/mgba/mgba-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /games-emulation/mgba/mgba-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'games-emulation/mgba/mgba-9999.ebuild')
-rw-r--r--games-emulation/mgba/mgba-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/games-emulation/mgba/mgba-9999.ebuild b/games-emulation/mgba/mgba-9999.ebuild
index be2689f439b2..d1d5df90464f 100644
--- a/games-emulation/mgba/mgba-9999.ebuild
+++ b/games-emulation/mgba/mgba-9999.ebuild
@@ -14,12 +14,12 @@ else
MY_PV="${PV/_beta/-b}"
SRC_URI="https://github.com/${PN}-emu/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
[[ "${PV}" == *_beta* ]] || \
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
S="${WORKDIR}/${PN}-${MY_PV}"
fi
LICENSE="MPL-2.0"
SLOT="0"
-IUSE="debug discord elf ffmpeg opengl qt5 +sdl sqlite"
+IUSE="debug discord elf ffmpeg gles2 gles3 opengl qt5 +sdl sqlite"
REQUIRED_USE="|| ( qt5 sdl )
qt5? ( opengl )"
@@ -28,7 +28,7 @@ RDEPEND="
sys-libs/zlib[minizip]
elf? ( dev-libs/elfutils )
ffmpeg? ( media-video/ffmpeg:= )
- opengl? ( virtual/opengl )
+ opengl? ( media-libs/libglvnd )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
@@ -39,7 +39,10 @@ RDEPEND="
sdl? ( media-libs/libsdl2[X,sound,joystick,video,opengl?] )
sqlite? ( dev-db/sqlite:3 )
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ gles2? ( media-libs/libglvnd )
+ gles3? ( media-libs/libglvnd )
+"
src_prepare() {
xdg_environment_reset
@@ -55,6 +58,8 @@ src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
-DBUILD_GL="$(usex opengl)"
+ -DBUILD_GLES2="$(usex gles2)"
+ -DBUILD_GLES3="$(usex gles3)"
-DBUILD_PYTHON=OFF
-DBUILD_QT="$(usex qt5)"
-DBUILD_SDL="$(usex sdl)"