summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-input-sdl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-emulation/mupen64plus-input-sdl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/mupen64plus-input-sdl')
-rw-r--r--games-emulation/mupen64plus-input-sdl/Manifest3
-rw-r--r--games-emulation/mupen64plus-input-sdl/metadata.xml11
-rw-r--r--games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild76
3 files changed, 90 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-input-sdl/Manifest b/games-emulation/mupen64plus-input-sdl/Manifest
new file mode 100644
index 000000000000..6def5f917f8a
--- /dev/null
+++ b/games-emulation/mupen64plus-input-sdl/Manifest
@@ -0,0 +1,3 @@
+DIST mupen64plus-input-sdl-src-2.5.tar.gz 50580 BLAKE2B ab75c6e200c2979c75d35082a426266e7f835e0731058f8013d8788802ab9d65363b8820326fbfedc0b384facfaeccf6e04da66e01f79aee3d420f3ebe385461 SHA512 014a5e21feb88b14bcee44a74556a257393b799745308421a611eb3b6c11a390a589fdd393f07e69a128ca60426d4dcf8847bcbabed77b0d570be282550148d6
+EBUILD mupen64plus-input-sdl-2.5.ebuild 1681 BLAKE2B 5eb74028c1914c4057e43fbb5a195111f22a9593db41519ebe7a189d4264791ccb8b3672c79b9f60f5923c50e6c8209c6dd9fb93b12c989058a395c649a5a0db SHA512 42ac79a06506801717db1692bc86813a5737ebafceebfa1e498cd0bef25abc58fe55b28897230a70cdf870ec01e80f079203f4ed2618055e2b820f8163177e46
+MISC metadata.xml 345 BLAKE2B ad9e66275eecd48b36aea9d14bea0b3651adcafdccc82542761d9c8bf2636f2c56f31b7d4e451bbdf0108de016d923b998f59a4ed774a2becb1cde66bf95dd01 SHA512 52f335099ec233825167226c8c15e6b270820eb111c8b89bcb91a4606f7b1d1d79ed12f41ac5ee69d973137c618f038ff55e395097fb1f1517692083ca86c294
diff --git a/games-emulation/mupen64plus-input-sdl/metadata.xml b/games-emulation/mupen64plus-input-sdl/metadata.xml
new file mode 100644
index 000000000000..92306ce86d63
--- /dev/null
+++ b/games-emulation/mupen64plus-input-sdl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mupen64plus/mupen64plus-input-sdl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild
new file mode 100644
index 000000000000..fe28b341357a
--- /dev/null
+++ b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL input plugin"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=
+ media-libs/libsdl2:0=[joystick]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch_user
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+}