summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-video-rice
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-16 12:27:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-16 12:27:58 +0100
commitb6fa31c964a602f8461a77d5b83355e8750c12eb (patch)
tree323fa7af31640b3ea8bb57fa7a927713f3d64769 /games-emulation/mupen64plus-video-rice
parent868fd5dc8aab84930cfaa5252b8be06b35552765 (diff)
gentoo auto-resync : 16:07:2024 - 12:27:58
Diffstat (limited to 'games-emulation/mupen64plus-video-rice')
-rw-r--r--games-emulation/mupen64plus-video-rice/Manifest2
-rw-r--r--games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.6.0.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-video-rice/Manifest b/games-emulation/mupen64plus-video-rice/Manifest
index 392398a10c1b..b7da3c40dc01 100644
--- a/games-emulation/mupen64plus-video-rice/Manifest
+++ b/games-emulation/mupen64plus-video-rice/Manifest
@@ -1,3 +1,5 @@
DIST mupen64plus-video-rice-src-2.5.9.tar.gz 300964 BLAKE2B 652d6642b743703488465883de2fe1e83e873316f133322fce343a6c8f3be37f351a1a91bad56ee1b4568afcafee55c1cb3cd6679159e24c552df63174751376 SHA512 98be11217024408e7c61120e7eb3cf83d6c9f666a029c7d0e85790c885c99e795336a8fa4f5029e546eba8cc139c6a5e84dd6c2ae5c60784a90c27ce58cd0603
+DIST mupen64plus-video-rice-src-2.6.0.tar.gz 303629 BLAKE2B c418fee926ae38ee6e98eb45a0290f1ed724883327cc15d3b08f1540bfa6ae6e371cd5fd47df8eea4c0c8d0ccb16ba34cd9f240c37dc66899e2d1992114054a8 SHA512 a0a5c37cedbd493ede3bc715fe8251a8055b93119eeae89034c970bbb24e2d175d0bbf9640341ec20cfe9566fd4abd60fae6931a68cce8aa34eb8f9e278c94fb
EBUILD mupen64plus-video-rice-2.5.9-r2.ebuild 1867 BLAKE2B a70eebb487d1e15f88150cda0a779bb5390a94f43ebd6ccaa5ecbad044c0b037f900497a9bc2c879ff382b7d8eec7225cfd69dd1b072fe0b8e7003148c52a922 SHA512 63a0153abf3f07d93d4de07e2ecbeebaa6b4b11141ae608dd7e5ca0e6bd035f5d08950bacf9ade4e28511f6927760bd9cdaef108cbff420d2ac7783f0b50f055
+EBUILD mupen64plus-video-rice-2.6.0.ebuild 1874 BLAKE2B fff2f5106de523a7f12c422777e8f54342f8fc3c7b55605d41ebc354b2a6de42ce3ec2dd3597fe9d8f3f7d4e4ddee6b51f3c76b69de7e0e87ba9b226f8cd6d85 SHA512 6ea72e32733a7fb31cf8014f2b96df490ce51d638f3d87092ce432825c1de41a67e201d1a48e4c0821cac7a7ece8d62dd90855ef63d8a85ac11b384cb33f85fb
MISC metadata.xml 347 BLAKE2B 8c6dea98e0c59caedf807cbc174ad5a97da95f955c6e3c33b5f2de4d5cad3952b1dbc014c6c90a74f64f1474d46f512662580d6fc83d4d2e1ceefc7f7d64affe SHA512 6135ddf80341a59741c2641696639c524305131f46361ffc03cb5080d55658eaa26074702c63c696b3fe4cadb8c8d2fd8ebeac4bf03b0029dc283be579bd4e5a
diff --git a/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.6.0.ebuild b/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.6.0.ebuild
new file mode 100644
index 000000000000..1ed2d4307bdb
--- /dev/null
+++ b/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.6.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P=${PN}-src-${PV}
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, rice video plugin"
+HOMEPAGE="https://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gles2-only cpu_flags_x86_sse"
+
+DEPEND="
+ >=games-emulation/mupen64plus-core-2.5:0=[gles2-only=]
+ media-libs/libpng:0=
+ media-libs/libsdl2:0=[video]
+ virtual/opengl:0=
+ gles2-only? ( media-libs/libsdl2:0[gles2] )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+
+ NO_ASM=$(usex cpu_flags_x86_sse 0 1)
+ USE_GLES=$(usex gles2-only 1 0)
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ dodoc README RELEASE
+}