summaryrefslogtreecommitdiff
path: root/games-emulation/openmsx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /games-emulation/openmsx
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'games-emulation/openmsx')
-rw-r--r--games-emulation/openmsx/Manifest3
-rw-r--r--games-emulation/openmsx/files/sdl-ttf.patch12
-rw-r--r--games-emulation/openmsx/openmsx-0.14.0.ebuild19
3 files changed, 28 insertions, 6 deletions
diff --git a/games-emulation/openmsx/Manifest b/games-emulation/openmsx/Manifest
index a2465372542c..225c5a8b6569 100644
--- a/games-emulation/openmsx/Manifest
+++ b/games-emulation/openmsx/Manifest
@@ -1,3 +1,4 @@
+AUX sdl-ttf.patch 383 BLAKE2B 78cea0b0c7dc1074022baadf3694adac1c809d3f280a8abef4038954f8fd486a71936a0f98a064eb8fdf8e8dfe82341016931ba52b43aa645f6c9d2a83768632 SHA512 e0d5259ce13254e53bd760130930bba96be977bc308a66c937e7fb68d42266cfa48775baf0df72d23f1c955c684dd73efdece4ef7e0398fe793e330c99edfbca
DIST openmsx-0.14.0.tar.gz 3338719 BLAKE2B e9c09d29bb994f4f40e22271c090580688724cb7024910f0f829a59d0e65e6e70e1c037b943582aac644ee51a00b7e439e751bd84e5828168486b74ee09e8b78 SHA512 74a30de89b4a7cb4d8d5a0ad0c16ab6b58244251ebcbe470cc3cccec6a636492fa8779d1667d76646eabcf8d7d67c53094d5e0a313d452a4a679d797e9394a9b
-EBUILD openmsx-0.14.0.ebuild 1647 BLAKE2B 97b6ed516383c7162051dbf19ec1805b28b3df9a5845f44fd01a30a898b3078827a1a78026b3b113dd45f472f408d1d165e266b0bf2fa4746aa33e187f9cf27a SHA512 47f3bb94878edc3303c467a552262fed6c3aa0d539ef4a6981e9705b4e4166200126f6da93e1e1e6bcf78b38e102d5ebe22c2c5e9f93a0557cb21b2370e9fed9
+EBUILD openmsx-0.14.0.ebuild 1748 BLAKE2B 5a46938c0d955bab6b659747645293799c03b4c259da31b28efaf5b6014ddbfc9eb1d1db4f1fabbb607269e89a8624e5bdbc9ceb0cf009823ff10afd1eb9247a SHA512 457423e2350fac1d363ac33244556f20b1def51a2ed8623800d70619029d0ed960f3eca0d76730b74d14a4688a762dedf4123b206f286485e2eebf2d69f7bb0d
MISC metadata.xml 330 BLAKE2B 0557bfe5901a6eb7331ad400d19b438dd3125b0af9426dd7c5bc369e3e5769677e645529b71c19797a57b4e3a43440a94664e80fa941e414a2b29e209382190d SHA512 0e2cbbe9308c1a43be6617797af0abe91bfa1dbb604ef9bc96dfb7c6c7310799c689ff7450afd9eb5b66d7aaeda878e0d046b404a0220b69b5dcf38be346e422
diff --git a/games-emulation/openmsx/files/sdl-ttf.patch b/games-emulation/openmsx/files/sdl-ttf.patch
new file mode 100644
index 000000000000..6ff469e509ed
--- /dev/null
+++ b/games-emulation/openmsx/files/sdl-ttf.patch
@@ -0,0 +1,12 @@
+diff -Naur a/build/libraries.py b/build/libraries.py
+--- a/build/libraries.py 2017-08-03 11:26:28.000000000 +0100
++++ b/build/libraries.py 2018-08-29 23:11:04.392981071 +0100
+@@ -304,7 +304,7 @@
+ class SDL_ttf(Library):
+ libName = 'SDL_ttf'
+ makeName = 'SDL_TTF'
+- header = '<SDL_ttf.h>'
++ header = '<SDL/SDL_ttf.h>'
+ function = 'TTF_OpenFont'
+ dependsOn = ('SDL', 'FREETYPE')
+
diff --git a/games-emulation/openmsx/openmsx-0.14.0.ebuild b/games-emulation/openmsx/openmsx-0.14.0.ebuild
index 8b39565b4be2..42d560e04cdc 100644
--- a/games-emulation/openmsx/openmsx-0.14.0.ebuild
+++ b/games-emulation/openmsx/openmsx-0.14.0.ebuild
@@ -1,17 +1,19 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit desktop readme.gentoo-r1
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop python-any-r1 readme.gentoo-r1
DESCRIPTION="MSX emulator that aims for perfection"
HOMEPAGE="http://openmsx.org/"
-SRC_URI="https://github.com/openMSX/openMSX/releases/download/RELEASE_0_14_0/${P}.tar.gz"
+SRC_URI="https://github.com/openMSX/openMSX/releases/download/RELEASE_${PV//./_}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE=""
RDEPEND="
dev-lang/tcl:0=
@@ -23,7 +25,14 @@ RDEPEND="
media-libs/sdl-ttf
virtual/opengl
"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ "${FILESDIR}"/sdl-ttf.patch
+)
DOC_CONTENTS="
If you want to if you want to emulate real MSX systems and not