summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-23 05:29:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-23 05:29:14 +0100
commit7f740fcb9a0165d81bfecf7fb5da647763d76a1b (patch)
tree45dab58d8bd40ef97234398e9e1850495ea60273 /games-emulation/pcsx2/files
parent0bf5c5a0b1ff93d1f4aaa8cdea6acda5e42c2068 (diff)
gentoo auto-resync : 23:09:2022 - 05:29:13
Diffstat (limited to 'games-emulation/pcsx2/files')
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.3329-clang16.patch19
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.3329-lto.patch21
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.3329-musl.patch9
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.3329-qt6.patch10
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.3329-unbundle.patch41
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.3329-wx-vs-sdl.patch9
6 files changed, 109 insertions, 0 deletions
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.3329-clang16.patch b/games-emulation/pcsx2/files/pcsx2-1.7.3329-clang16.patch
new file mode 100644
index 000000000000..331101ed6a1c
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.3329-clang16.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/870412
+--- a/3rdparty/cpuinfo/src/api.c
++++ b/3rdparty/cpuinfo/src/api.c
+@@ -78 +78 @@
+-const struct cpuinfo_uarch_info* cpuinfo_get_uarchs() {
++const struct cpuinfo_uarch_info* cpuinfo_get_uarchs(void) {
+--- a/cmake/FindPCAP.cmake
++++ b/cmake/FindPCAP.cmake
+@@ -47 +47 @@
+-check_c_source_compiles("int main() { return 0; }" PCAP_LINKS_SOLO)
++check_c_source_compiles("int main(void) { return 0; }" PCAP_LINKS_SOLO)
+@@ -55 +55 @@
+- check_c_source_compiles("int main() { return 0; }" PCAP_NEEDS_THREADS)
++ check_c_source_compiles("int main(void) { return 0; }" PCAP_NEEDS_THREADS)
+--- a/tests/ctest/CMakeLists.txt
++++ b/tests/ctest/CMakeLists.txt
+@@ -20 +20 @@
+- int main() {
++ int main(void) {
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.3329-lto.patch b/games-emulation/pcsx2/files/pcsx2-1.7.3329-lto.patch
new file mode 100644
index 000000000000..1047105d646a
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.3329-lto.patch
@@ -0,0 +1,21 @@
+Lazy fix for -Werror=odr and don't rely on the CMAKE macro to
+pass -fno-lto to the problematic FastJmp.cpp source with lto.
+--- a/common/CMakeLists.txt
++++ b/common/CMakeLists.txt
+@@ -268,3 +268,3 @@
+
+-if (USE_GCC AND CMAKE_INTERPROCEDURAL_OPTIMIZATION)
++if (USE_GCC)
+ # GCC LTO doesn't work with asm statements
+--- a/pcsx2/PAD/Linux/Device.h
++++ b/pcsx2/PAD/Linux/Device.h
+@@ -31,3 +31,3 @@
+
+-enum DeviceType
++enum PADDeviceType
+ {
+@@ -101,3 +101,3 @@
+ DeviceAPI api;
+- DeviceType type;
++ PADDeviceType type;
+
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.3329-musl.patch b/games-emulation/pcsx2/files/pcsx2-1.7.3329-musl.patch
new file mode 100644
index 000000000000..95d2ff38a8c2
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.3329-musl.patch
@@ -0,0 +1,9 @@
+--- a/pcsx2/USB/qemu-usb/iov.h
++++ b/pcsx2/USB/qemu-usb/iov.h
+@@ -17,5 +17,5 @@
+ #define IOV_H
+
+-#if !defined(_BITS_UIO_H) && !defined(__iovec_defined) /* /usr/include/bits/uio.h */
++#if !defined(_BITS_UIO_H) && !defined(__iovec_defined) && !defined(__DEFINED_struct_iovec)
+ struct iovec
+ {
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.3329-qt6.patch b/games-emulation/pcsx2/files/pcsx2-1.7.3329-qt6.patch
new file mode 100644
index 000000000000..9ef82985dc99
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.3329-qt6.patch
@@ -0,0 +1,10 @@
+https://github.com/PCSX2/pcsx2/commit/6386be09c2e disabled PACKAGE_MODE
+for reasons that make no sense as far as installing from an ebuild goes.
+
+Skip the error and handle the rest from the ebuild.
+--- a/pcsx2-qt/CMakeLists.txt
++++ b/pcsx2-qt/CMakeLists.txt
+@@ -7,3 +7,2 @@
+ if (PACKAGE_MODE)
+- message(FATAL_ERROR "Package mode is not supported for Qt builds.")
+ else()
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.3329-unbundle.patch b/games-emulation/pcsx2/files/pcsx2-1.7.3329-unbundle.patch
new file mode 100644
index 000000000000..450329522183
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.3329-unbundle.patch
@@ -0,0 +1,41 @@
+Adjust to unbundle a few extras.
+
+zstd changes only needed because of https://bugs.gentoo.org/872254
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -54,3 +54,4 @@
+ set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
+- add_subdirectory(3rdparty/gtest EXCLUDE_FROM_ALL)
++ find_package(GTest REQUIRED)
++ alias_library(gtest_main GTest::gtest_main)
+ add_subdirectory(tests/ctest)
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -177,3 +177,3 @@
+ set(ACTUALLY_ENABLE_TESTS ${ENABLE_TESTS})
+-if(ENABLE_TESTS)
++if(0)
+ if(NOT EXISTS "${CMAKE_SOURCE_DIR}/3rdparty/gtest/CMakeLists.txt")
+@@ -210,7 +210,4 @@
+ find_optional_system_library(ryml 3rdparty/rapidyaml/rapidyaml 0.4.0)
+-find_optional_system_library(zstd 3rdparty/zstd 1.4.5)
+-if (${zstd_TYPE} STREQUAL System)
+- alias_library(Zstd::Zstd zstd::libzstd_shared)
+- alias_library(pcsx2-zstd zstd::libzstd_shared)
+-endif()
++pkg_check_modules(zstd REQUIRED IMPORTED_TARGET libzstd)
++alias_library(Zstd::Zstd PkgConfig::zstd)
+ find_optional_system_library(libzip 3rdparty/libzip 1.8.0)
+@@ -243,3 +240,4 @@
+ add_subdirectory(3rdparty/lzma EXCLUDE_FROM_ALL)
+-add_subdirectory(3rdparty/libchdr EXCLUDE_FROM_ALL)
++pkg_check_modules(chdr REQUIRED IMPORTED_TARGET libchdr)
++alias_library(chdr-static PkgConfig::chdr)
+
+@@ -269,5 +267,3 @@
+ if(CUBEB_API)
+- add_subdirectory(3rdparty/cubeb EXCLUDE_FROM_ALL)
+- target_compile_options(cubeb PRIVATE "-w")
+- target_compile_options(speex PRIVATE "-w")
++ find_package(cubeb REQUIRED)
+ endif()
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.3329-wx-vs-sdl.patch b/games-emulation/pcsx2/files/pcsx2-1.7.3329-wx-vs-sdl.patch
new file mode 100644
index 000000000000..d00f9553993d
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.3329-wx-vs-sdl.patch
@@ -0,0 +1,9 @@
+This check is unnecessary, bit dodgy (ldd+grep), and requires -DSDL2_API=1
+/only/ if wxGTK was built with USE=sdl or else get a cmake unused options
+warning. Test code also fails with -Werror=strict-prototypes (clang16).
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -191,3 +191,2 @@
+ if(NOT PCSX2_CORE)
+- WX_vs_SDL()
+ endif()