summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-27 22:51:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-27 22:51:10 +0000
commitee0c4d5e506a6c64994a15c3af5cf1ca22045567 (patch)
treebdf578939023d42f04092ddb4bcd190eb391770f /games-emulation/pcsx2/files
parent161eaa4b12ca6314376288834bba20b7824d0d77 (diff)
gentoo auto-resync : 27:11:2023 - 22:51:09
Diffstat (limited to 'games-emulation/pcsx2/files')
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.5232-cubeb-automagic.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.5232-cubeb-automagic.patch b/games-emulation/pcsx2/files/pcsx2-1.7.5232-cubeb-automagic.patch
new file mode 100644
index 000000000000..e195ae79c3b1
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.5232-cubeb-automagic.patch
@@ -0,0 +1,31 @@
+Same that media-libs/cubeb does and meant for -DLAZY_LOAD_LIBS=no.
+
+Unfortunately need to use bundled cubeb here given it modifies the
+source starting with (but not likely limited to):
+https://github.com/PCSX2/pcsx2/commit/9170a5abc1
+--- a/3rdparty/cubeb/CMakeLists.txt
++++ b/3rdparty/cubeb/CMakeLists.txt
+@@ -76,3 +76,5 @@
+
++ if(CHECK_PULSE)
+ pkg_check_modules(libpulse IMPORTED_TARGET libpulse)
++ endif()
+ if(libpulse_FOUND)
+@@ -83,3 +85,5 @@
+
++ if(CHECK_ALSA)
+ pkg_check_modules(alsa IMPORTED_TARGET alsa)
++ endif()
+ if(alsa_FOUND)
+@@ -90,3 +94,5 @@
+
++ if(CHECK_JACK)
+ pkg_check_modules(jack IMPORTED_TARGET jack)
++ endif()
+ if(jack_FOUND)
+@@ -97,3 +103,5 @@
+
++ if(CHECK_SNDIO)
+ check_include_files(sndio.h USE_SNDIO)
++ endif()
+ if(USE_SNDIO)