summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2/pcsx2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-26 09:08:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-26 09:08:49 +0100
commit720452fca3cdf447b4c65bc3bb363032a983309e (patch)
treebabdd1cb196da2b5da2e481505e2e492cb4fe458 /games-emulation/pcsx2/pcsx2-9999.ebuild
parent5923f7107d7596f9ecb6a86b451105462668601c (diff)
gentoo auto-resync : 26:05:2023 - 09:08:49
Diffstat (limited to 'games-emulation/pcsx2/pcsx2-9999.ebuild')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index be8593008a14..1c93197e9991 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -156,8 +156,14 @@ src_prepare() {
}
src_configure() {
- # for bundled glslang (bug #858374)
- use vulkan && append-flags -fno-strict-aliasing
+ if use vulkan; then
+ # for bundled glslang (bug #858374)
+ append-flags -fno-strict-aliasing
+
+ # odr violations in pcsx2's vulkan code, disabling as a safety for now
+ # (vulkan support tend to receive major changes, is more on WIP side)
+ filter-lto
+ fi
local mycmakeargs=(
$(cmake_use_find_package backtrace Libbacktrace)