summaryrefslogtreecommitdiff
path: root/games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild')
-rw-r--r--games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild b/games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild
index f8d068fed3ca..672c8ccbccb4 100644
--- a/games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild
+++ b/games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake xdg-utils
+inherit flag-o-matic xdg cmake
EGIT_COMMIT="62467b86871aee3d70c7445f3cb79f0858ec566e"
MY_P=${PN}-${EGIT_COMMIT}
@@ -36,17 +36,16 @@ RDEPEND="
ccdda? ( >=media-video/ffmpeg-3:= )
openal? ( media-libs/openal:= )
pulseaudio? ( media-sound/pulseaudio:= )
- sdl? ( media-libs/libsdl2:=[sound] )
-"
+ sdl? ( media-libs/libsdl2:=[sound] )"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
BDEPEND="
app-arch/unzip
dev-util/intltool
- sys-devel/gettext:0
-"
+ sys-devel/gettext:0"
src_configure() {
+ append-cflags -fcommon
local sound_backend
if use pulseaudio; then
@@ -78,11 +77,3 @@ src_install() {
mv "${ED}"/usr/share/doc/pcsxr/* "${ED}/usr/share/doc/${PF}/" || die
rmdir "${ED}"/usr/share/doc/pcsxr || die
}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}