summaryrefslogtreecommitdiff
path: root/games-emulation/prosystem-jg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
commit3392d5e937023e57811edc670b0ed7d3aba55c6d (patch)
tree32c103a9b86223dcc05105e88f05d471bcaf0886 /games-emulation/prosystem-jg
parent046c3c0984fd20387a9f86cdd0842fd81e70d94f (diff)
gentoo auto-resync : 15:01:2023 - 17:55:24
Diffstat (limited to 'games-emulation/prosystem-jg')
-rw-r--r--games-emulation/prosystem-jg/Manifest4
-rw-r--r--games-emulation/prosystem-jg/metadata.xml24
-rw-r--r--games-emulation/prosystem-jg/prosystem-jg-1.5.1.ebuild45
-rw-r--r--games-emulation/prosystem-jg/prosystem-jg-9999.ebuild45
4 files changed, 118 insertions, 0 deletions
diff --git a/games-emulation/prosystem-jg/Manifest b/games-emulation/prosystem-jg/Manifest
new file mode 100644
index 000000000000..cb6c2b4535b3
--- /dev/null
+++ b/games-emulation/prosystem-jg/Manifest
@@ -0,0 +1,4 @@
+DIST prosystem-1.5.1.tar.bz2 49454 BLAKE2B 40c392805de577d2275c4810e36b6489a1457920484631bc63a54bef7c6120f5bef114bc52e17b65a43ccfc7c13b84694ea40376845217bae306a19940991a56 SHA512 daa3f40bc490299cdfb93393e95f411be7225dfe5271b2767ca7f5ef422ed053c3255b952de041ef44b7a196cb780b292f37a12104aef299c15ac564b77d281f
+EBUILD prosystem-jg-1.5.1.ebuild 869 BLAKE2B 63ca99b4bfe4523ca7f21313cfe3645d7189b442da01f4c79baed93c13469c1187865a93988bb7999d1186467a38526a254cb8d756eace640edbc1088173bcd9 SHA512 3ed19830a838dfab16f7601b4edc93db8b945c47a1264a228b62a1e23a45871ec33092e57fd8ab85fbfff19fc62340d6857318280a7899edf7eb483fb5d18056
+EBUILD prosystem-jg-9999.ebuild 869 BLAKE2B 63ca99b4bfe4523ca7f21313cfe3645d7189b442da01f4c79baed93c13469c1187865a93988bb7999d1186467a38526a254cb8d756eace640edbc1088173bcd9 SHA512 3ed19830a838dfab16f7601b4edc93db8b945c47a1264a228b62a1e23a45871ec33092e57fd8ab85fbfff19fc62340d6857318280a7899edf7eb483fb5d18056
+MISC metadata.xml 884 BLAKE2B c86e3143336e94fb0a7dd7c570a0f17215c96ab470905ca1ba65915c3671b686d4f5ffa7c41e7b9c1935572a6cd17a6c8a6895a989ffcca7e0203164b02fc92c SHA512 292bea12e40b13b5c3bc060f8122fa62428468a1b21c0f420c01c4056082335928a9f26db4f24a8c9694e59f3c2e6e7dbaa37067ab8424284dac1ad9aa90557a
diff --git a/games-emulation/prosystem-jg/metadata.xml b/games-emulation/prosystem-jg/metadata.xml
new file mode 100644
index 000000000000..e4fc9179d308
--- /dev/null
+++ b/games-emulation/prosystem-jg/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ ProSystem JG is an emulator for the Atari 7800. This
+ is a fork of ProSystem 1.3e with patches from OpenEmu,
+ which contains patches derived from Wii7800 and js7800.
+ The code has been significantly altered. It was ported
+ from C++ to C, and all of the dependencies and Windows-
+ specific code were removed.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/prosystem/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/prosystem</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-emulation/prosystem-jg/prosystem-jg-1.5.1.ebuild b/games-emulation/prosystem-jg/prosystem-jg-1.5.1.ebuild
new file mode 100644
index 000000000000..212b4dd7a4b3
--- /dev/null
+++ b/games-emulation/prosystem-jg/prosystem-jg-1.5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of ProSystem"
+HOMEPAGE="https://gitlab.com/jgemu/prosystem"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD GPL-2+"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/prosystem-jg/prosystem-jg-9999.ebuild b/games-emulation/prosystem-jg/prosystem-jg-9999.ebuild
new file mode 100644
index 000000000000..212b4dd7a4b3
--- /dev/null
+++ b/games-emulation/prosystem-jg/prosystem-jg-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of ProSystem"
+HOMEPAGE="https://gitlab.com/jgemu/prosystem"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD GPL-2+"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}