summaryrefslogtreecommitdiff
path: root/games-emulation/sameboy-jg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-21 08:09:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-21 08:09:25 +0000
commit5adb1b3ff590f0911922679849a7fdacc8b4f217 (patch)
tree8a471fe02dd3498487715d39f928b42017f24c99 /games-emulation/sameboy-jg
parentafcb9236a72cf602364c28b9bde6648e4a7f1ca5 (diff)
gentoo auto-resync : 21:01:2024 - 08:09:25
Diffstat (limited to 'games-emulation/sameboy-jg')
-rw-r--r--games-emulation/sameboy-jg/Manifest4
-rw-r--r--games-emulation/sameboy-jg/sameboy-jg-0.16.2.ebuild49
-rw-r--r--games-emulation/sameboy-jg/sameboy-jg-9999.ebuild4
3 files changed, 54 insertions, 3 deletions
diff --git a/games-emulation/sameboy-jg/Manifest b/games-emulation/sameboy-jg/Manifest
index 96432810a534..bd449204111b 100644
--- a/games-emulation/sameboy-jg/Manifest
+++ b/games-emulation/sameboy-jg/Manifest
@@ -1,4 +1,6 @@
DIST sameboy-0.15.8.tar.bz2 3002961 BLAKE2B 5eacbc82d8c93ee85b774c554b3d3750088e8a4219d5b04daa9e6db0c70923ef823befc12831382a27ee007f117fddcfe35ff3549d7684b8587db9ffc486ccd6 SHA512 9074dfcbf400fe51e605ef0200f6ea8483650d605ab19177089c0e60f9996c15f265c5dec5fd0e6651392c9a9515e8380499e00bac837bb645220cd6ffa9c870
+DIST sameboy-0.16.2.tar.bz2 3556441 BLAKE2B 0972cb8ba200d8ac95a3d66e3b671c1adeeea71eebb4202b1985f7f72edebd42886aac48040bf034dab8d93fd52d15165551ee8dfaf6870a59ca7f574fc99e0f SHA512 bd456e248ec2d6ea0e8b017b705c829c6a94b1f7fe734769a86774c4b6983278cc5b4d61fdf8164844545bbd250b3c4f1fe725046ac7edb301268291d907f39f
EBUILD sameboy-jg-0.15.8.ebuild 987 BLAKE2B 2dcce119bf6ad54ef4977b6053679c4587404de366365f5f8b929b543b4b6aa6a59f11d2be70252df5d81cbf7009ab1afa00236bc616d4e83b565f7199d66eb6 SHA512 130951e3bb86eea3730ebebefdad1527dce767f3dc38789f446954aa3ecacedae1cdc911c5e43f86f3c8947cc9b8ccefc32f9378af04a3936330a09591daa8be
-EBUILD sameboy-jg-9999.ebuild 953 BLAKE2B 80f8f6a3128b07075774bf2dac2ee6626c6c5a9bb46198d0a80b1108d36256c4eea5798e3ad2f58ab0201e3df4e80d86e69c1323e53f792c2464eb7684f4d94b SHA512 03a56fae6b8803163f621be338f6a71bc924581305afae0f4b1a0c634749ebac465769e74b074f055ccc1b77f80e21051e2ebea116eea0270728663d09c2bd7b
+EBUILD sameboy-jg-0.16.2.ebuild 987 BLAKE2B 2dcce119bf6ad54ef4977b6053679c4587404de366365f5f8b929b543b4b6aa6a59f11d2be70252df5d81cbf7009ab1afa00236bc616d4e83b565f7199d66eb6 SHA512 130951e3bb86eea3730ebebefdad1527dce767f3dc38789f446954aa3ecacedae1cdc911c5e43f86f3c8947cc9b8ccefc32f9378af04a3936330a09591daa8be
+EBUILD sameboy-jg-9999.ebuild 987 BLAKE2B 2dcce119bf6ad54ef4977b6053679c4587404de366365f5f8b929b543b4b6aa6a59f11d2be70252df5d81cbf7009ab1afa00236bc616d4e83b565f7199d66eb6 SHA512 130951e3bb86eea3730ebebefdad1527dce767f3dc38789f446954aa3ecacedae1cdc911c5e43f86f3c8947cc9b8ccefc32f9378af04a3936330a09591daa8be
MISC metadata.xml 708 BLAKE2B a3b2b3fc9e8fd4d954a58950d2f71218aaf491f15361bf3aae171bf1ad980e8008f0d4eac174d2c1ffcc0a9684a25c8018de728c5921dee0c4c72aa1d9f4eb2b SHA512 39ddb36f6f470e3206be465a5bb5a691b9b68881d2f5f002362f7617bd6a9c4b62a8afaaa70ba88e3c62dde678ef2409e8746ba70d70295278e974633d2936af
diff --git a/games-emulation/sameboy-jg/sameboy-jg-0.16.2.ebuild b/games-emulation/sameboy-jg/sameboy-jg-0.16.2.ebuild
new file mode 100644
index 000000000000..c41503e9640a
--- /dev/null
+++ b/games-emulation/sameboy-jg/sameboy-jg-0.16.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of SameBoy"
+HOMEPAGE="https://gitlab.com/jgemu/sameboy"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ >=dev-util/rgbds-0.6.0
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake -C jollygood \
+ CC="$(tc-getCC)" \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/sameboy-jg/sameboy-jg-9999.ebuild b/games-emulation/sameboy-jg/sameboy-jg-9999.ebuild
index 2a20f4b0419c..c41503e9640a 100644
--- a/games-emulation/sameboy-jg/sameboy-jg-9999.ebuild
+++ b/games-emulation/sameboy-jg/sameboy-jg-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,7 @@ if [[ "${PV}" == *9999 ]] ; then
else
SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
S="${WORKDIR}/${MY_P}"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi
LICENSE="MIT"