summaryrefslogtreecommitdiff
path: root/games-emulation/snes9x/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
commit115dcc7054f5934a2c8e26fd8a8eed5f3e29e9ce (patch)
treec31afe35699960753f76770d6b0b4ea48af9f686 /games-emulation/snes9x/files
parente292b671b113c2cc012beddad93a3df4f9410698 (diff)
gentoo auto-resync : 28:03:2023 - 09:49:10
Diffstat (limited to 'games-emulation/snes9x/files')
-rw-r--r--games-emulation/snes9x/files/snes9x-1.62.1-flags.patch24
-rw-r--r--games-emulation/snes9x/files/snes9x-1.62.1-gcc13.patch20
-rw-r--r--games-emulation/snes9x/files/snes9x-1.62.1-optional-wayland.patch16
3 files changed, 60 insertions, 0 deletions
diff --git a/games-emulation/snes9x/files/snes9x-1.62.1-flags.patch b/games-emulation/snes9x/files/snes9x-1.62.1-flags.patch
new file mode 100644
index 000000000000..7b3b4dad399b
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-1.62.1-flags.patch
@@ -0,0 +1,24 @@
+Avoid forcing -O3 and let users set these as wanted.
+--- a/libretro/Makefile
++++ b/libretro/Makefile
+@@ -579,6 +579,6 @@
+ CXXFLAGS += -O2 -DNDEBUG
+ else
+- CFLAGS += -O3 -DNDEBUG
+- CXXFLAGS += -O3 -DNDEBUG
++ CFLAGS += -DNDEBUG
++ CXXFLAGS += -DNDEBUG
+ endif
+
+--- a/unix/configure.ac
++++ b/unix/configure.ac
+@@ -65,9 +65,4 @@
+ AC_S9X_COMPILER_FLAG([-g], [g])
+ AC_S9X_COMPILER_FLAG([-O0], [o0])
+-else
+- AC_S9X_COMPILER_FLAG([-O3], [o3], [
+- AC_S9X_COMPILER_FLAG([-O2], [o2], [
+- AC_S9X_COMPILER_FLAG([-O1], [o1])])])
+- AC_S9X_COMPILER_FLAG([-fomit-frame-pointer], [omit_frame_pointer])
+ fi
+
diff --git a/games-emulation/snes9x/files/snes9x-1.62.1-gcc13.patch b/games-emulation/snes9x/files/snes9x-1.62.1-gcc13.patch
new file mode 100644
index 000000000000..28945fd782fc
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-1.62.1-gcc13.patch
@@ -0,0 +1,20 @@
+Partly a backport from
+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator/commit/29d492b60c8
+--- a/external/VulkanMemoryAllocator-Hpp/include/vk_mem_alloc.h
++++ b/external/VulkanMemoryAllocator-Hpp/include/vk_mem_alloc.h
+@@ -2615,4 +2615,8 @@
+ #endif
+
++#if VMA_STATS_STRING_ENABLED
++ #include <cstdio> // For snprintf
++#endif
++
+ /*******************************************************************************
+ CONFIGURATION SECTION
+--- a/vulkan/slang_shader.hpp
++++ b/vulkan/slang_shader.hpp
+@@ -1,3 +1,4 @@
+ #pragma once
++#include <cstdint>
+ #include <string>
+ #include <vector>
diff --git a/games-emulation/snes9x/files/snes9x-1.62.1-optional-wayland.patch b/games-emulation/snes9x/files/snes9x-1.62.1-optional-wayland.patch
new file mode 100644
index 000000000000..396f76a9d641
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-1.62.1-optional-wayland.patch
@@ -0,0 +1,16 @@
+USE_SLANG currently disregards whether USE_WAYLAND was used or not
+and leads to trying to use wayland headers that may be missing.
+--- a/gtk/CMakeLists.txt
++++ b/gtk/CMakeLists.txt
+@@ -99,8 +99,10 @@
+
+ list(APPEND DEFINES "VK_USE_PLATFORM_XLIB_KHR"
+- "VK_USE_PLATFORM_WAYLAND_KHR"
+ "VULKAN_HPP_DISPATCH_LOADER_DYNAMIC=1"
+ "VMA_DYNAMIC_VULKAN_FUNCTIONS=1"
+ "VMA_STATIC_VULKAN_FUNCTIONS=0")
++ if(USE_WAYLAND)
++ list(APPEND DEFINES "VK_USE_PLATFORM_WAYLAND_KHR")
++ endif()
+ list(APPEND INCLUDES ../external/vulkan-headers/include)
+ list(APPEND INCLUDES ../external/VulkanMemoryAllocator-Hpp/include)