summaryrefslogtreecommitdiff
path: root/games-emulation/snes9x/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /games-emulation/snes9x/files
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'games-emulation/snes9x/files')
-rw-r--r--games-emulation/snes9x/files/snes9x-1.60-gcc11.patch47
-rw-r--r--games-emulation/snes9x/files/snes9x-1.61-libretro-flags.patch25
2 files changed, 25 insertions, 47 deletions
diff --git a/games-emulation/snes9x/files/snes9x-1.60-gcc11.patch b/games-emulation/snes9x/files/snes9x-1.60-gcc11.patch
deleted file mode 100644
index 453771f5139c..000000000000
--- a/games-emulation/snes9x/files/snes9x-1.60-gcc11.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 7f6d9d6432d912cd90763c64f7c92270b3e6c182 Mon Sep 17 00:00:00 2001
-From: gocha <gochaism@gmail.com>
-Date: Sun, 19 Jan 2020 12:48:06 +0900
-Subject: [PATCH] win32: fix compilation error in vs2019
-
----
- conffile.cpp | 2 +-
- conffile.h | 6 +++---
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/conffile.cpp b/conffile.cpp
-index 817afae7f..fa7de3fa2 100644
---- a/conffile.cpp
-+++ b/conffile.cpp
-@@ -452,7 +452,7 @@ void ConfigFile::ClearLines()
- }
- }
-
--bool ConfigFile::ConfigEntry::section_then_key_less::operator()(const ConfigEntry &a, const ConfigEntry &b) {
-+bool ConfigFile::ConfigEntry::section_then_key_less::operator()(const ConfigEntry &a, const ConfigEntry &b) const{
- if(curConfigFile && a.section!=b.section){
- const int sva = curConfigFile->GetSectionSize(a.section);
- const int svb = curConfigFile->GetSectionSize(b.section);
-diff --git a/conffile.h b/conffile.h
-index ba69812df..d92128cba 100644
---- a/conffile.h
-+++ b/conffile.h
-@@ -90,7 +90,7 @@ class ConfigFile {
- mutable bool used;
-
- struct section_then_key_less {
-- bool operator()(const ConfigEntry &a, const ConfigEntry &b);
-+ bool operator()(const ConfigEntry &a, const ConfigEntry &b) const;
- };
-
- struct key_less {
-@@ -101,8 +101,8 @@ class ConfigFile {
- };
-
- struct line_less {
-- bool operator()(const ConfigEntry &a, const ConfigEntry &b){
-- if(a.line==b.line) return (b.val.empty() && !a.val.empty()) || a.key<b.key;
-+ bool operator()(const ConfigEntry &a, const ConfigEntry &b) const{
-+ if(a.line==b.line) return (b.val.empty() && !a.val.empty()) || a.key<b.key;
- if(b.line<0) return true;
- if(a.line<0) return false;
- return a.line<b.line;
diff --git a/games-emulation/snes9x/files/snes9x-1.61-libretro-flags.patch b/games-emulation/snes9x/files/snes9x-1.61-libretro-flags.patch
new file mode 100644
index 000000000000..297c7d78257d
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-1.61-libretro-flags.patch
@@ -0,0 +1,25 @@
+CXXFLAGS is used as a "common" flags variable and passed to CFLAGS,
+but want to use user's CFLAGS for CC rather than CXXFLAGS. Workaround
+with a temporary variable and also drop -O3/lto from defaults.
+--- a/libretro/Makefile
++++ b/libretro/Makefile
+@@ -4,3 +4,5 @@
+
+-LTO ?= -flto
++LTO :=
++ORIG_CXXFLAGS := $(CXXFLAGS)
++CXXFLAGS :=
+ SPACE :=
+@@ -580,4 +582,4 @@
+ else
+- CFLAGS += -O3 -DNDEBUG
+- CXXFLAGS += -O3 -DNDEBUG
++ CFLAGS += -DNDEBUG
++ CXXFLAGS += -DNDEBUG
+ endif
+@@ -612,3 +614,4 @@
+ CXXFLAGS += -DRIGHTSHIFT_IS_SAR -D__LIBRETRO__ -DALLOW_CPU_OVERCLOCK
+-CFLAGS := $(CXXFLAGS)
++CFLAGS := $(CXXFLAGS) $(CFLAGS)
++CXXFLAGS += $(ORIG_CXXFLAGS)
+ CFLAGS += -DHAVE_STDINT_H