summaryrefslogtreecommitdiff
path: root/games-emulation/zinc/zinc-1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
commit2f8db31405fac68eea6f7257d58529243815033b (patch)
tree54259cc8988a98a10586fc0496b1f3501cd1e2a1 /games-emulation/zinc/zinc-1.1-r1.ebuild
parenta4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (diff)
gentoo resync : 30.04.2018
Diffstat (limited to 'games-emulation/zinc/zinc-1.1-r1.ebuild')
-rw-r--r--games-emulation/zinc/zinc-1.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-emulation/zinc/zinc-1.1-r1.ebuild b/games-emulation/zinc/zinc-1.1-r1.ebuild
new file mode 100644
index 000000000000..69f75f4b58ff
--- /dev/null
+++ b/games-emulation/zinc/zinc-1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An x86 binary-only emulator for Sony ZN-1, ZN-2, and Namco System 11 arcades"
+HOMEPAGE="http://caesar.logiqx.com/php/emulator.php?id=zinc_linux"
+SRC_URI="http://caesar.logiqx.com/zips/emus/linux/zinc_linux/${P//[-.]/}-lnx.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+QA_PREBUILT="/opt/bin/zinc /usr/lib*/*.so"
+
+RDEPEND="
+ x11-libs/libXext[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+"
+
+S="${WORKDIR}/zinc"
+
+src_install() {
+ exeinto /opt/bin
+ doexe zinc
+ dolib.so libcontrolznc.so librendererznc.so libsoundznc.so libs11player.so
+ einstalldocs
+}