summaryrefslogtreecommitdiff
path: root/games-engines/box2d/box2d-2.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /games-engines/box2d/box2d-2.4.1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'games-engines/box2d/box2d-2.4.1.ebuild')
-rw-r--r--games-engines/box2d/box2d-2.4.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/games-engines/box2d/box2d-2.4.1.ebuild b/games-engines/box2d/box2d-2.4.1.ebuild
new file mode 100644
index 000000000000..63093288e008
--- /dev/null
+++ b/games-engines/box2d/box2d-2.4.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ engine for simulating rigid bodies in 2D games"
+HOMEPAGE="https://box2d.org/"
+SRC_URI="https://github.com/erincatto/Box2D/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOX2D_BUILD_TESTBED=OFF # bundled libs, broken anyway right now
+ -DBOX2D_BUILD_DOCS=$(usex doc)
+ )
+ cmake_src_configure
+}