summaryrefslogtreecommitdiff
path: root/games-engines/devilutionx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-23 19:24:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-23 19:24:10 +0000
commit575bcb9220287a6f0d2577db1fd9fe55d9d8b745 (patch)
tree52f12cfa140d4839d32305dd42eebe34e9686234 /games-engines/devilutionx
parent4c5bd80830992553e02f099442277e10ee97372d (diff)
gentoo auto-resync : 23:02:2025 - 19:24:09
Diffstat (limited to 'games-engines/devilutionx')
-rw-r--r--games-engines/devilutionx/Manifest2
-rw-r--r--games-engines/devilutionx/devilutionx-1.5.4.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/games-engines/devilutionx/Manifest b/games-engines/devilutionx/Manifest
index a04c6c05df30..333c4a00e382 100644
--- a/games-engines/devilutionx/Manifest
+++ b/games-engines/devilutionx/Manifest
@@ -1,3 +1,5 @@
DIST devilutionx-1.5.3.tar.xz 22394112 BLAKE2B 1b04c7fe334ddfd6b1eb619b1e86c1e429f6c26c980a16129d8322bb30641409d9d11a203e42ccdbce60a05e00dc49b1a2acbdd1007c5f99e40b88acd1251440 SHA512 619873bb232d1b344f5001c232364af9cfcda72e44f28fd2a15332292fa37c0e64b7fccade3570b96bd648be235ed56e0cc2e3fd8299ac57ef26f2ce844cbc2f
+DIST devilutionx-1.5.4.tar.xz 22665424 BLAKE2B 2debdc0235618bf3b244da4b6ef48af45c0940bba7b923fefec3d1a2183e80459b5a997440008d56fe9483cb84e2b78c6eff41e21b4c25617fba067e7e27f704 SHA512 1d601453a826d4a214f851844c1b6e68114ac099f152464edbabe4e6bfd4553746ab1e6da83a01e6318e83f8e559000052a991fbfb7e88c6f1a7e9d059ab3380
EBUILD devilutionx-1.5.3-r1.ebuild 2127 BLAKE2B d839e2e3758188a7cea06e1424ac5ed37bf3eef59e6f2a140e5bdffa08a3fadca5a2fd04fad0f9b5fa56670f934928c267fb92934f06870e75203b2aefd3131f SHA512 22cc4132815bd5053c80ac2312abeaa8317febe0f6cf2c3e283ba77854ff8c09f7bd9e0045e5f9af7d161daf2c4492a6a55dd7de6a9d9263af75ec0dffa1f0f0
+EBUILD devilutionx-1.5.4.ebuild 2127 BLAKE2B 6f086184f4c3d91aec77b790f9c6440aadd955a20e6b121db10e02e1962673bf587102082a4e9d7f7b2fd2ddfab9c2028cf4492da5f767749daf84e46507c445 SHA512 9de845cf95d9c89f88a8c7751da88cd9985b925b6d291ef5ddb35df8535d4ec4353b956d8e0687929bcdd68f4302e05d59697630468e1fd40bd9b3f2be5c94ac
MISC metadata.xml 542 BLAKE2B 25e292f201570a11d08f4f22922a9dfa1f54d51784be9b38f3b8396a44559ffe6d5f8799e20b8c2fa888ce97e8a45d257894c13924e303a7f93d04c0c046e231 SHA512 acb1603f7e41f47daf7f9fde6128b2f7c51c277cb97be62b87695cceb48fca653f90c2ca3e22238758a78aae4fa34f2de555e07f7e8d896a8ccf5e1c569e8083
diff --git a/games-engines/devilutionx/devilutionx-1.5.4.ebuild b/games-engines/devilutionx/devilutionx-1.5.4.ebuild
new file mode 100644
index 000000000000..9584fcf8ac5e
--- /dev/null
+++ b/games-engines/devilutionx/devilutionx-1.5.4.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Diablo engine for modern operating systems"
+HOMEPAGE="https://github.com/diasurgical/devilutionX/"
+SRC_URI="
+ https://github.com/diasurgical/devilutionX/releases/download/${PV}/devilutionx-src.tar.xz
+ -> ${P}.tar.xz
+"
+S=${WORKDIR}/${PN}-src-${PV}
+
+LICENSE="
+ Sustainable-Use-1.0
+ BSD CC-BY-4.0 GPL-2+ LGPL-2.1+ MIT OFL-1.1
+ zerotier? ( BUSL-1.1 )
+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +sodium test zerotier"
+RESTRICT="bindist mirror !test? ( test )"
+
+RDEPEND="
+ app-arch/bzip2:=
+ dev-libs/libfmt:=
+ media-libs/libsdl2[haptic,joystick,opengl,video]
+ media-libs/sdl2-image[png]
+ media-libs/sdl_audiolib
+ sys-libs/zlib:=
+ sodium? ( dev-libs/libsodium:= )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/asio
+ dev-cpp/simpleini
+ test? ( dev-cpp/gtest )
+"
+BDEPEND="
+ sys-devel/gettext
+"
+
+CMAKE_SKIP_TESTS=(
+ # timedemo tests only pass when game assets are available
+ Timedemo.
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # use system asio
+ echo 'add_library(asio INTERFACE)' > 3rdParty/asio/CMakeLists.txt || die
+
+ # ensure system copies are used
+ rm -r dist/{asio,simpleini,sdl_audiolib}-src || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DCCACHE_PROGRAM=no #813768
+ -DDEBUG=$(usex debug)
+ -DDISABLE_LTO=yes # let CFLAGS control this
+ -DDISABLE_ZERO_TIER=$(usex !zerotier)
+ -DPACKET_ENCRYPTION=$(usex sodium)
+ -DPIE=yes
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ local DOCS=( Packaging/nix/README.txt docs/*.md )
+ cmake_src_install
+
+ rm -- "${ED}"/usr/share/diasurgical/devilutionx/README.txt || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "In order to play the game, you will need to copy the following data file"
+ elog "from the original game, and optionally the hellfire expansion files:"
+ elog " - DIABDAT.MPQ"
+ elog " - hellfire.mpq hfmonk.mpq hfmusic.mpq hfvoice.mpq"
+ elog "to ~/.local/share/diasurgical/devilution/"
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.txt* for details."
+ fi
+}