summaryrefslogtreecommitdiff
path: root/games-engines/frotz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-engines/frotz
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-engines/frotz')
-rw-r--r--games-engines/frotz/Manifest5
-rw-r--r--games-engines/frotz/files/frotz-2.43-glibc2.10.patch29
-rw-r--r--games-engines/frotz/files/frotz-2.43-ldflags.patch20
-rw-r--r--games-engines/frotz/frotz-2.43-r1.ebuild52
-rw-r--r--games-engines/frotz/metadata.xml11
5 files changed, 117 insertions, 0 deletions
diff --git a/games-engines/frotz/Manifest b/games-engines/frotz/Manifest
new file mode 100644
index 000000000000..fa77a80eb365
--- /dev/null
+++ b/games-engines/frotz/Manifest
@@ -0,0 +1,5 @@
+AUX frotz-2.43-glibc2.10.patch 859 BLAKE2B 6d8994a0bc80d9bc24ed76e6016f549b7c6b9cbcf9ed081b3ba4ebedee872bf9e04a7b62a1d8995da5942f3a8c271cf67287d4d4d96b5f3998b9561ea7c6ede6 SHA512 467477b2740667b1f8356845f7ec30a8318120313dc2bbfa2bcbde2c9cde77269349b6e7076397a7c837d9a1e72aa8fe59007fd73bd0de14b6c8244514fb81d2
+AUX frotz-2.43-ldflags.patch 665 BLAKE2B 0c744231190a308761c73f847ea6842259f424cb5ae33f1cc8311e7dc77a3ac9dd85bfc7f99070980042ab83418dd2b3b5a17c4ff29527065eb9d473ded85cff SHA512 9d750679169daa67fcd6580edd5dd53f80ab490e2637d524be9525f99764b5203242a9f9e93262d9c1abcc6d62b994f7d943040931b30ab2ce1ac9a6b772e107
+DIST frotz-2.43.tar.gz 160771 BLAKE2B edee48050b247320df3d02ea4682579d4f933a5853cc9a31f56c4d12596d5e5657e79e176ed1725e72028497a843db1d0b13833ffe44e41ec7f532f0d40ccaf9 SHA512 654f2ca2d1a625df8f88b5629e09a873668cea42688acdf154636b066b94fc9d70b7f45acb33a71d234c19b59c394c63aee38d6224245b3b329210e6b4a58409
+EBUILD frotz-2.43-r1.ebuild 1075 BLAKE2B a3ff1a05881e507a648516abc200721ecedb9ab7cf87f4b6b7673fdcd0114228309274c64f67a242404c21af16bea3cd3319f3c586e4a22e7cf69ef163e6f66f SHA512 00953652ed45fe80f9332758e5399afbbb479d2ef74f1e4e50e7eddda4566e57b4aaf2d51649f792f91abc75a580b8e3ccd677a3fc9bf1af5f07f2c710ad7e16
+MISC metadata.xml 328 BLAKE2B 650d86497c2eb4a36a16c14f088d691a6a586917592b4e3192bb321bb7007f402cbfc45cb272556a78831bab46fe57bde78f6db6b459d26064856f8308a9c19a SHA512 37fcc943d9d2700b5d88e71666af1a3ebe5baf905095d864066ebe20ac7edd54bfcafacc31684ae1eeed5197096cecbfec57c01ff5be1b567af1cc21c7294d6a
diff --git a/games-engines/frotz/files/frotz-2.43-glibc2.10.patch b/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
new file mode 100644
index 000000000000..3f2639ec47d0
--- /dev/null
+++ b/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
@@ -0,0 +1,29 @@
+--- a/src/dumb/dumb_input.c
++++ b/src/dumb/dumb_input.c
+@@ -79,7 +79,7 @@
+ /* Read one line, including the newline, into s. Safely avoids buffer
+ * overruns (but that's kind of pointless because there are several
+ * other places where I'm not so careful). */
+-static void getline(char *s)
++static void get_line(char *s)
+ {
+ int c;
+ char *p = s;
+@@ -203,7 +203,7 @@
+ fputs(prompt, stdout);
+ else
+ dumb_show_prompt(show_cursor, (timeout ? "tTD" : ")>}")[type]);
+- getline(s);
++ get_line(s);
+ if ((s[0] != '\\') || ((s[1] != '\0') && !islower(s[1]))) {
+ /* Is not a command line. */
+ translate_special_chars(s);
+@@ -265,7 +265,7 @@
+ if (!*current_page)
+ break;
+ printf("HELP: Type <return> for more, or q <return> to stop: ");
+- getline(s);
++ get_line(s);
+ if (!strcmp(s, "q\n"))
+ break;
+ }
diff --git a/games-engines/frotz/files/frotz-2.43-ldflags.patch b/games-engines/frotz/files/frotz-2.43-ldflags.patch
new file mode 100644
index 000000000000..c8b4e35eee20
--- /dev/null
+++ b/games-engines/frotz/files/frotz-2.43-ldflags.patch
@@ -0,0 +1,20 @@
+--- a/Makefile 2010-10-04 14:13:37.000000000 +0200
++++ b/Makefile 2010-10-04 14:14:06.000000000 +0200
+@@ -162,7 +162,7 @@
+ $(NAME): $(NAME)-curses
+
+ $(NAME)-curses: soundcard.h $(COMMON_TARGET) $(CURSES_TARGET)
+- $(CC) -o $(BINNAME)$(EXTENSION) $(TARGETS) $(LIB) $(CURSES) \
++ $(CC) $(LDFLAGS) -o $(BINNAME)$(EXTENSION) $(TARGETS) $(LIB) $(CURSES) \
+ $(SOUND_LIB)
+
+ all: $(NAME) d$(NAME)
+@@ -170,7 +170,7 @@
+ dumb: $(NAME)-dumb
+ d$(NAME): $(NAME)-dumb
+ $(NAME)-dumb: $(COMMON_TARGET) $(DUMB_TARGET)
+- $(CC) -o d$(BINNAME)$(EXTENSION) $(COMMON_TARGET) \
++ $(CC) $(LDFLAGS) -o d$(BINNAME)$(EXTENSION) $(COMMON_TARGET) \
+ $(DUMB_TARGET) $(LIB)
+
+ .SUFFIXES:
diff --git a/games-engines/frotz/frotz-2.43-r1.ebuild b/games-engines/frotz/frotz-2.43-r1.ebuild
new file mode 100644
index 000000000000..08d19d78526c
--- /dev/null
+++ b/games-engines/frotz/frotz-2.43-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Curses based interpreter for Z-code based text games"
+HOMEPAGE="http://frotz.sourceforge.net/"
+SRC_URI="http://www.ifarchive.org/if-archive/infocom/interpreters/frotz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa oss"
+
+DEPEND="sys-libs/ncurses:0
+ alsa? ( oss? ( media-libs/alsa-oss ) )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc2.10.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CC /d' \
+ Makefile \
+ || die
+}
+
+src_compile() {
+ local OPTS="CONFIG_DIR=/etc"
+ use oss && OPTS="${OPTS} SOUND_DEFS=-DOSS_SOUND SOUND_DEV=/dev/dsp"
+ emake ${OPTS} all
+}
+
+src_install () {
+ dobin {d,}frotz
+ doman doc/*.6
+ dodoc AUTHORS BUGS ChangeLog HOW_TO_PLAY README TODO \
+ doc/{frotz.conf-big,frotz.conf-small}
+}
+
+pkg_postinst() {
+ echo
+ elog "Global config file can be installed in /etc/frotz.conf"
+ elog "Sample config files are in /usr/share/doc/${PF}"
+ echo
+}
diff --git a/games-engines/frotz/metadata.xml b/games-engines/frotz/metadata.xml
new file mode 100644
index 000000000000..051541926fbb
--- /dev/null
+++ b/games-engines/frotz/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">frotz</remote-id>
+ </upstream>
+</pkgmetadata>